1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-03 00:02:20 +03:00

Use the in-kernel pwc driver, no need to maintain it externally

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7450 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2007-06-02 14:51:00 +00:00
parent 1daccd1cf7
commit ddb57e0d8e
4 changed files with 3 additions and 69 deletions

View File

@ -306,6 +306,9 @@ define KernelPackage/usb-pwc/2.4
FILES:=$(LINUX_DIR)/drivers/usb/pwc.$(LINUX_KMOD_SUFFIX)
endef
define KernelPackage/usb-pwc/2.6
FILES:=$(LINUX_DIR)/drivers/usb/media/pwc/pwc.$(LINUX_KMOD_SUFFIX)
endef
$(eval $(call KernelPackage,usb-pwc))
define KernelPackage/usb-net

View File

@ -1,44 +0,0 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=pwc
PKG_VERSION:=10.0.12-rc1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.saillard.org/linux/pwc/files/
PKG_MD5SUM:=8763f3d6fd0f9738ef9854de205a126d
include $(INCLUDE_DIR)/package.mk
define KernelPackage/pwc
TITLE:=USB Philips camera driver
DESCRIPTION:=Kernel support for USB Philips camera
SUBMENU:=USB Support
DEPENDS:=@BROKEN @LINUX_2_6 @VIDEO_SUPPORT
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
FILES:=$(PKG_BUILD_DIR)/pwc.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,70,$(shell cat ./files/pwc.modules))
endef
define Build/Compile
$(MAKE) -C $(LINUX_DIR) \
PATH="$(TARGET_PATH)" \
KVER="$(LINUX_VERSION)" \
KSRC="$(LINUX_DIR)" \
SUBDIRS="$(PKG_BUILD_DIR)" \
KERNEL_DIR="$(KERNEL_DIR)" \
ARCH="$(LINUX_KARCH)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
modules
endef
$(eval $(call KernelPackage,pwc))

View File

@ -1 +0,0 @@
pwc

View File

@ -1,24 +0,0 @@
diff -ur pwc.old/pwc.h pwc.dev/pwc.h
--- pwc.old/pwc.h 2006-04-13 23:38:43.000000000 +0200
+++ pwc.dev/pwc.h 2007-01-22 02:04:03.872800960 +0100
@@ -25,7 +25,7 @@
#ifndef PWC_H
#define PWC_H
-#include <linux/config.h>
+#include <linux/autoconf.h>
#include <linux/module.h>
#include <linux/usb.h>
#include <linux/spinlock.h>
diff -ur pwc.old/pwc-uncompress.h pwc.dev/pwc-uncompress.h
--- pwc.old/pwc-uncompress.h 2006-01-07 12:57:47.000000000 +0100
+++ pwc.dev/pwc-uncompress.h 2007-01-22 02:04:18.129633592 +0100
@@ -30,7 +30,7 @@
#ifndef PWC_UNCOMPRESS_H
#define PWC_UNCOMPRESS_H
-#include <linux/config.h>
+#include <linux/autoconf.h>
#include "pwc-ioctl.h"