1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-04 21:34:32 +03:00

libpcap: properly fix fPIC handling (reverts $(FPIC) added in r26999)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27000 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2011-05-24 10:42:49 +00:00
parent 2f232288ee
commit e0b1d7ab25
4 changed files with 42 additions and 19 deletions

View File

@ -38,7 +38,6 @@ define Package/libpcap/config
endef endef
TARGET_CFLAGS += \ TARGET_CFLAGS += \
$(FPIC) \
-ffunction-sections \ -ffunction-sections \
-fdata-sections -fdata-sections

View File

@ -61,7 +61,7 @@ build a shared library.
MAN1 = pcap-config.1 MAN1 = pcap-config.1
@@ -324,7 +338,7 @@ EXTRA_DIST = \ @@ -324,21 +338,14 @@ EXTRA_DIST = \
Win32/Src/inet_net.c \ Win32/Src/inet_net.c \
Win32/Src/inet_pton.c Win32/Src/inet_pton.c
@ -70,7 +70,22 @@ build a shared library.
libpcap.a: $(OBJ) libpcap.a: $(OBJ)
@rm -f $@ @rm -f $@
@@ -409,6 +423,13 @@ libpcap.shareda: $(OBJ) ar rc $@ $(OBJ) $(ADDLARCHIVEOBJS)
$(RANLIB) $@
-shared: libpcap.$(DYEXT)
-
-libpcap.so: $(OBJ)
- @rm -f $@
- VER=`cat $(srcdir)/VERSION`; \
- MAJOR_VER=`sed 's/\([0-9][0-9]*\)\..*/\1/' $(srcdir)/VERSION`; \
- @V_SHLIB_CMD@ @V_SHLIB_OPT@ @V_SONAME_OPT@$@.$$MAJOR_VER $(LDFLAGS) \
- -o $@.$$VER $(OBJ) $(ADDLOBJS) $(LIBS)
+shared: $(SHAREDLIB)
#
# The following rule succeeds, but the result is untested.
@@ -409,6 +416,13 @@ libpcap.shareda: $(OBJ)
# #
libpcap.none: libpcap.none:
@ -84,7 +99,7 @@ build a shared library.
scanner.c: $(srcdir)/scanner.l scanner.c: $(srcdir)/scanner.l
@rm -f $@ @rm -f $@
$(srcdir)/runlex.sh $(LEX) -o$@ $< $(srcdir)/runlex.sh $(LEX) -o$@ $<
@@ -416,6 +437,9 @@ scanner.c: $(srcdir)/scanner.l @@ -416,6 +430,9 @@ scanner.c: $(srcdir)/scanner.l
scanner.o: scanner.c tokdefs.h scanner.o: scanner.c tokdefs.h
$(CC) $(CFLAGS) -c scanner.c $(CC) $(CFLAGS) -c scanner.c
@ -94,7 +109,7 @@ build a shared library.
pcap.o: version.h pcap.o: version.h
tokdefs.h: grammar.c tokdefs.h: grammar.c
@@ -429,9 +453,17 @@ grammar.o: grammar.c @@ -429,9 +446,17 @@ grammar.o: grammar.c
@rm -f $@ @rm -f $@
$(CC) $(CFLAGS) -Dyylval=pcap_lval -c grammar.c $(CC) $(CFLAGS) -Dyylval=pcap_lval -c grammar.c
@ -112,7 +127,7 @@ build a shared library.
snprintf.o: $(srcdir)/missing/snprintf.c snprintf.o: $(srcdir)/missing/snprintf.c
$(CC) $(CFLAGS) -o $@ -c $(srcdir)/missing/snprintf.c $(CC) $(CFLAGS) -o $@ -c $(srcdir)/missing/snprintf.c
@@ -469,6 +501,9 @@ bpf_filter.c: $(srcdir)/bpf/net/bpf_filt @@ -469,6 +494,9 @@ bpf_filter.c: $(srcdir)/bpf/net/bpf_filt
bpf_filter.o: bpf_filter.c bpf_filter.o: bpf_filter.c
$(CC) $(CFLAGS) -c bpf_filter.c $(CC) $(CFLAGS) -c bpf_filter.c
@ -122,16 +137,25 @@ build a shared library.
# #
# Generate the pcap-config script. # Generate the pcap-config script.
# #
@@ -604,6 +639,9 @@ install-archive-so install-archive-dylib @@ -562,14 +590,12 @@ install: install-shared install-archive
$(DESTDIR)$(mandir)/man@MAN_MISC_INFO@/`echo $$i | sed 's/.manmisc.in/.@MAN_MISC_INFO@/'`; done
install-shared: install-shared-$(DYEXT)
-install-shared-so: libpcap.so
+install-shared-so: $(SHAREDLIB)
[ -d $(DESTDIR)$(libdir) ] || \
(mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir)) (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
$(INSTALL_DATA) libpcap.a $(DESTDIR)$(libdir)/libpcap.a - VER=`cat $(srcdir)/VERSION`; \
$(RANLIB) $(DESTDIR)$(libdir)/libpcap.a - MAJOR_VER=`sed 's/\([0-9][0-9]*\)\..*/\1/' $(srcdir)/VERSION`; \
- $(INSTALL_PROGRAM) libpcap.so.$$VER $(DESTDIR)$(libdir)/libpcap.so.$$VER; \
- ln -sf libpcap.so.$$VER $(DESTDIR)$(libdir)/libpcap.so.$$MAJOR_VER; \
- ln -sf libpcap.so.$$MAJOR_VER $(DESTDIR)$(libdir)/libpcap.so
+ $(INSTALL_DATA) $(SHAREDLIB) $(DESTDIR)$(libdir)/ + $(INSTALL_DATA) $(SHAREDLIB) $(DESTDIR)$(libdir)/
+ ln -sf $(SHAREDLIB) $(DESTDIR)$(libdir)/$(SOLIBRARY).$(MAJ) + ln -sf $(SHAREDLIB) $(DESTDIR)$(libdir)/$(SOLIBRARY).$(MAJ)
+ ln -sf $(SOLIBRARY).$(MAJ) $(DESTDIR)$(libdir)/$(SOLIBRARY) + ln -sf $(SOLIBRARY).$(MAJ) $(DESTDIR)$(libdir)/$(SOLIBRARY)
install-archive-shareda: install-shared-dylib: libpcap.dylib
# [ -d $(DESTDIR)$(libdir) ] || \
# AIX, however, doesn't, so we don't install the archive (mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
--- a/configure --- a/configure
+++ b/configure +++ b/configure
@@ -3229,7 +3229,7 @@ _ACEOF @@ -3229,7 +3229,7 @@ _ACEOF

View File

@ -1,6 +1,6 @@
--- a/Makefile.in --- a/Makefile.in
+++ b/Makefile.in +++ b/Makefile.in
@@ -539,62 +539,12 @@ install: install-shared install-archive @@ -532,62 +532,12 @@ install: install-shared install-archive
(mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir)) (mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
[ -d $(DESTDIR)$(includedir)/pcap ] || \ [ -d $(DESTDIR)$(includedir)/pcap ] || \
(mkdir -p $(DESTDIR)$(includedir)/pcap; chmod 755 $(DESTDIR)$(includedir)/pcap) (mkdir -p $(DESTDIR)$(includedir)/pcap; chmod 755 $(DESTDIR)$(includedir)/pcap)
@ -62,8 +62,8 @@
- $(DESTDIR)$(mandir)/man@MAN_MISC_INFO@/`echo $$i | sed 's/.manmisc.in/.@MAN_MISC_INFO@/'`; done - $(DESTDIR)$(mandir)/man@MAN_MISC_INFO@/`echo $$i | sed 's/.manmisc.in/.@MAN_MISC_INFO@/'`; done
install-shared: install-shared-$(DYEXT) install-shared: install-shared-$(DYEXT)
install-shared-so: libpcap.so install-shared-so: $(SHAREDLIB)
@@ -654,23 +604,6 @@ uninstall: uninstall-shared @@ -642,23 +592,6 @@ uninstall: uninstall-shared
rm -f $(DESTDIR)$(includedir)/$$i; done rm -f $(DESTDIR)$(includedir)/$$i; done
-rmdir $(DESTDIR)$(includedir)/pcap -rmdir $(DESTDIR)$(includedir)/pcap
rm -f $(DESTDIR)/$(bindir)/pcap-config rm -f $(DESTDIR)/$(bindir)/pcap-config

View File

@ -105,10 +105,11 @@
return (p); return (p);
} }
@@ -318,6 +320,15 @@ pcap_set_buffer_size(pcap_t *p, int buff @@ -317,6 +319,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
return 0;
} }
int +int
+pcap_set_protocol(pcap_t *p, unsigned short proto) +pcap_set_protocol(pcap_t *p, unsigned short proto)
+{ +{
+ if (pcap_check_activated(p)) + if (pcap_check_activated(p))
@ -117,10 +118,9 @@
+ return 0; + return 0;
+} +}
+ +
+int int
pcap_activate(pcap_t *p) pcap_activate(pcap_t *p)
{ {
int status;
--- a/pcap/pcap.h --- a/pcap/pcap.h
+++ b/pcap/pcap.h +++ b/pcap/pcap.h
@@ -68,6 +68,7 @@ extern "C" { @@ -68,6 +68,7 @@ extern "C" {