[backfire] remove goldfish-qemu, backfire has no glodfish target
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@21329 3c298f89-4303-0410-b956-a3cf2f4a3e73
@ -1,69 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=goldfish-qemu
|
||||
PKG_VERSION:=20090429
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=git://android.git.kernel.org/platform/external/qemu
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=2b8ea29e2bd12f876a4d06647e6077bf72de567e
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_TARGETS:=bin
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/goldfish-qemu
|
||||
SECTION:=emulator
|
||||
CATEGORY:=Emulators
|
||||
DEPENDS:=@TARGET_goldfish
|
||||
TITLE:=A modified version of the Google Android Emulator
|
||||
URL:=http://www.android.com/
|
||||
endef
|
||||
|
||||
LIBSDL_PATCHED:=sdl-1.2.12-android-20080919
|
||||
|
||||
define Download/libsdl-patched
|
||||
FILE:=$(LIBSDL_PATCHED).tar.gz
|
||||
URL:=http://android.git.kernel.org/pub
|
||||
MD5SUM:=22df8cbb2ecb811938eba8410e861650
|
||||
endef
|
||||
$(eval $(call Download,libsdl-patched))
|
||||
|
||||
Build/Exports=
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
zcat $(DL_DIR)/$(LIBSDL_PATCHED).tar.gz | tar x -C $(PKG_BUILD_DIR)
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
[ -x $(PKG_BUILD_DIR)/libsdl/bin/sdl-config ] || ( \
|
||||
cd $(PKG_BUILD_DIR)/$(LIBSDL_PATCHED); \
|
||||
./android-configure --prefix=$(PKG_BUILD_DIR)/libsdl; \
|
||||
make all install; \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
[ -f $(PKG_BUILD_DIR)/objs/config.make ] || \
|
||||
./android-configure.sh --sdl-config=$(PKG_BUILD_DIR)/libsdl/bin/sdl-config \
|
||||
)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
endef
|
||||
|
||||
define Package/goldfish-qemu/install
|
||||
$(INSTALL_DIR) $(1)
|
||||
$(CP) $(PKG_BUILD_DIR)/objs/emulator $(1)/
|
||||
$(CP) ./skins $(1)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,goldfish-qemu))
|
@ -1,30 +0,0 @@
|
||||
--- a/android-configure.sh
|
||||
+++ b/android-configure.sh
|
||||
@@ -656,6 +656,9 @@ case "$CPU" in
|
||||
*) HOST_CPU=$CPU
|
||||
;;
|
||||
esac
|
||||
+case "$OS" in
|
||||
+ darwin*) echo "#define _BSD 1" >> $config_h;;
|
||||
+esac
|
||||
echo "#define HOST_$HOST_CPU 1" >> $config_h
|
||||
log "Generate : $config_h"
|
||||
|
||||
--- a/android/utils/display-quartz.m
|
||||
+++ b/android/utils/display-quartz.m
|
||||
@@ -34,6 +34,7 @@ get_monitor_resolution( int *px_dpi, in
|
||||
int
|
||||
get_nearest_monitor_rect( int *x, int *y, int *width, int *height )
|
||||
{
|
||||
+#if 0
|
||||
SDL_SysWMinfo info;
|
||||
NSWindow* window;
|
||||
|
||||
@@ -108,4 +109,7 @@ get_nearest_monitor_rect( int *x, int
|
||||
}
|
||||
return 0;
|
||||
}
|
||||
+#else
|
||||
+ return -1;
|
||||
+#endif
|
||||
};
|
@ -1,233 +0,0 @@
|
||||
--- a/android/cmdline-option.c
|
||||
+++ b/android/cmdline-option.c
|
||||
@@ -50,16 +50,6 @@ android_parse_options( int *pargc, char
|
||||
char arg2_tab[64], *arg2 = arg2_tab;
|
||||
int nn;
|
||||
|
||||
- /* process @<name> as a special exception meaning
|
||||
- * '-avd <name>'
|
||||
- */
|
||||
- if (aread[0][0] == '@') {
|
||||
- opt->avd = aread[0]+1;
|
||||
- nargs--;
|
||||
- aread++;
|
||||
- continue;
|
||||
- }
|
||||
-
|
||||
/* anything that isn't an option past this points
|
||||
* exits the loop
|
||||
*/
|
||||
--- a/android/cmdline-options.h
|
||||
+++ b/android/cmdline-options.h
|
||||
@@ -60,21 +60,16 @@
|
||||
*/
|
||||
|
||||
CFG_PARAM( sysdir, "<dir>", "search for system disk images in <dir>" )
|
||||
-CFG_PARAM( system, "<file>", "read initial system image from <file>" )
|
||||
-CFG_PARAM( datadir, "<dir>", "write user data into <dir>" )
|
||||
-CFG_PARAM( kernel, "<file>", "use specific emulated kernel" )
|
||||
-CFG_PARAM( ramdisk, "<file>", "ramdisk image (default <system>/ramdisk.img" )
|
||||
-CFG_PARAM( image, "<file>", "obsolete, use -system <file> instead" )
|
||||
-CFG_PARAM( init_data, "<file>", "initial data image (default <system>/userdata.img" )
|
||||
-CFG_PARAM( initdata, "<file>", "same as '-init-data <file>'" )
|
||||
-CFG_PARAM( data, "<file>", "data image (default <datadir>/userdata-qemu.img" )
|
||||
+CFG_PARAM( system, "<file>", "read system image from <file>, default: <system>/system.img" )
|
||||
+CFG_PARAM( data, "<file>", "data image, default: <system>/data.img" )
|
||||
+CFG_PARAM( kernel, "<file>", "use specific emulated kernel, default: kernel.bin" )
|
||||
+CFG_PARAM( ramdisk, "<file>", "ramdisk image (default <system>/ramdisk.bin" )
|
||||
CFG_PARAM( partition_size, "<size>", "system/data partition size in MBs" )
|
||||
CFG_PARAM( cache, "<file>", "cache partition image (default is temporary file)" )
|
||||
CFG_FLAG ( no_cache, "disable the cache partition" )
|
||||
CFG_FLAG ( nocache, "same as -no-cache" )
|
||||
OPT_PARAM( sdcard, "<file>", "SD card image (default <system>/sdcard.img")
|
||||
OPT_FLAG ( wipe_data, "reset the use data image (copy it from initdata)" )
|
||||
-CFG_PARAM( avd, "<name>", "use a specific android virtual device" )
|
||||
CFG_PARAM( skindir, "<dir>", "search skins in <dir> (default <system>/skins)" )
|
||||
CFG_PARAM( skin, "<name>", "select a given skin" )
|
||||
CFG_FLAG ( no_skin, "don't use any emulator skin" )
|
||||
--- a/android/main.c
|
||||
+++ b/android/main.c
|
||||
@@ -1606,6 +1606,7 @@ report_console( const char* proto_port,
|
||||
* containing 'fileName'. this is *not* the full
|
||||
* path to 'fileName'.
|
||||
*/
|
||||
+
|
||||
static char*
|
||||
_getSdkImagePath( const char* fileName )
|
||||
{
|
||||
@@ -1617,8 +1618,6 @@ _getSdkImagePath( const char* fileName
|
||||
|
||||
static const char* const searchPaths[] = {
|
||||
"", /* program's directory */
|
||||
- "/lib/images", /* this is for SDK 1.0 */
|
||||
- "/../platforms/android-1.1/images", /* this is for SDK 1.1 */
|
||||
NULL
|
||||
};
|
||||
|
||||
@@ -1841,25 +1840,7 @@ int main(int argc, char **argv)
|
||||
}
|
||||
}
|
||||
|
||||
- /* legacy support: we used to use -system <dir> and -image <file>
|
||||
- * instead of -sysdir <dir> and -system <file>, so handle this by checking
|
||||
- * whether the options point to directories or files.
|
||||
- */
|
||||
- if (opts->image != NULL) {
|
||||
- if (opts->system != NULL) {
|
||||
- if (opts->sysdir != NULL) {
|
||||
- derror( "You can't use -sysdir, -system and -image at the same time.\n"
|
||||
- "You should probably use '-sysdir <path> -system <file>'.\n" );
|
||||
- exit(2);
|
||||
- }
|
||||
- }
|
||||
- dwarning( "Please note that -image is obsolete and that -system is now used to point\n"
|
||||
- "to the system image. Next time, try using '-sysdir <path> -system <file>' instead.\n" );
|
||||
- opts->sysdir = opts->system;
|
||||
- opts->system = opts->image;
|
||||
- opts->image = NULL;
|
||||
- }
|
||||
- else if (opts->system != NULL && path_is_dir(opts->system)) {
|
||||
+ if (opts->system != NULL && path_is_dir(opts->system)) {
|
||||
if (opts->sysdir != NULL) {
|
||||
derror( "Option -system should now be followed by a file path, not a directory one.\n"
|
||||
"Please use '-sysdir <path>' to point to the system directory.\n" );
|
||||
@@ -1885,49 +1866,11 @@ int main(int argc, char **argv)
|
||||
if (opts->noskin)
|
||||
opts->no_skin = opts->noskin;
|
||||
|
||||
- if (opts->initdata) {
|
||||
- opts->init_data = opts->initdata;
|
||||
- opts->initdata = NULL;
|
||||
- }
|
||||
-
|
||||
- /* If no AVD name was given, try to find the top of the
|
||||
- * Android build tree
|
||||
- */
|
||||
- if (opts->avd == NULL) {
|
||||
- do {
|
||||
- char* out = getenv("ANDROID_PRODUCT_OUT");
|
||||
-
|
||||
- if (out == NULL || out[0] == 0)
|
||||
- break;
|
||||
-
|
||||
- if (!path_exists(out)) {
|
||||
- derror("Can't access ANDROID_PRODUCT_OUT as '%s'\n"
|
||||
- "You need to build the Android system before launching the emulator",
|
||||
- out);
|
||||
- exit(2);
|
||||
- }
|
||||
-
|
||||
- android_build_root = path_parent( out, 4 );
|
||||
- if (android_build_root == NULL || !path_exists(android_build_root)) {
|
||||
- derror("Can't find the Android build root from '%s'\n"
|
||||
- "Please check the definition of the ANDROID_PRODUCT_OUT variable.\n"
|
||||
- "It should point to your product-specific build output directory.\n",
|
||||
- out );
|
||||
- exit(2);
|
||||
- }
|
||||
- android_build_out = out;
|
||||
- D( "found Android build root: %s", android_build_root );
|
||||
- D( "found Android build out: %s", android_build_out );
|
||||
- } while (0);
|
||||
- }
|
||||
/* if no virtual device name is given, and we're not in the
|
||||
* Android build system, we'll need to perform some auto-detection
|
||||
* magic :-)
|
||||
*/
|
||||
- if (opts->avd == NULL && !android_build_out)
|
||||
{
|
||||
- char dataDirIsSystem = 0;
|
||||
-
|
||||
if (!opts->sysdir) {
|
||||
opts->sysdir = _getSdkImagePath("system.img");
|
||||
if (!opts->sysdir) {
|
||||
@@ -1945,47 +1888,30 @@ int main(int argc, char **argv)
|
||||
}
|
||||
|
||||
if (!opts->system) {
|
||||
- opts->system = _getSdkSystemImage(opts->sysdir, "-image", "system.img");
|
||||
- D("autoconfig: -image %s", opts->image);
|
||||
+ opts->system = _getSdkSystemImage(opts->sysdir, "-system", "system.img");
|
||||
+ D("autoconfig: -system %s", opts->system);
|
||||
}
|
||||
|
||||
if (!opts->kernel) {
|
||||
- opts->kernel = _getSdkSystemImage(opts->sysdir, "-kernel", "kernel-qemu");
|
||||
+ opts->kernel = _getSdkSystemImage(opts->sysdir, "-kernel", "kernel.bin");
|
||||
D("autoconfig: -kernel %s", opts->kernel);
|
||||
}
|
||||
|
||||
if (!opts->ramdisk) {
|
||||
- opts->ramdisk = _getSdkSystemImage(opts->sysdir, "-ramdisk", "ramdisk.img");
|
||||
+ opts->ramdisk = _getSdkSystemImage(opts->sysdir, "-ramdisk", "ramdisk.bin");
|
||||
D("autoconfig: -ramdisk %s", opts->ramdisk);
|
||||
}
|
||||
|
||||
- /* if no data directory is specified, use the system directory */
|
||||
- if (!opts->datadir) {
|
||||
- opts->datadir = qemu_strdup(opts->sysdir);
|
||||
- dataDirIsSystem = 1;
|
||||
- D("autoconfig: -datadir %s", opts->sysdir);
|
||||
- }
|
||||
-
|
||||
if (!opts->data) {
|
||||
/* check for userdata-qemu.img in the data directory */
|
||||
- bufprint(tmp, tmpend, "%s/userdata-qemu.img", opts->datadir);
|
||||
- if (!path_exists(tmp)) {
|
||||
- derror(
|
||||
- "You did not provide the name of an Android Virtual Device\n"
|
||||
- "with the '-avd <name>' option. Read -help-avd for more information.\n\n"
|
||||
-
|
||||
- "If you *really* want to *NOT* run an AVD, consider using '-data <file>'\n"
|
||||
- "to specify a data partition image file (I hope you know what you're doing).\n"
|
||||
- );
|
||||
- exit(2);
|
||||
- }
|
||||
+ bufprint(tmp, tmpend, "%s/data.img", opts->sysdir);
|
||||
|
||||
opts->data = qemu_strdup(tmp);
|
||||
D("autoconfig: -data %s", opts->data);
|
||||
}
|
||||
|
||||
- if (!opts->sdcard && opts->datadir) {
|
||||
- bufprint(tmp, tmpend, "%s/sdcard.img", opts->datadir);
|
||||
+ if (!opts->sdcard && opts->sysdir) {
|
||||
+ bufprint(tmp, tmpend, "%s/sdcard.img", opts->sysdir);
|
||||
if (path_exists(tmp)) {
|
||||
opts->sdcard = qemu_strdup(tmp);
|
||||
D("autoconfig: -sdcard %s", opts->sdcard);
|
||||
@@ -2029,19 +1955,6 @@ int main(int argc, char **argv)
|
||||
android_avdParams->skinName = opts->skin;
|
||||
android_avdParams->skinRootPath = opts->skindir;
|
||||
|
||||
- /* setup the virtual device differently depending on whether
|
||||
- * we are in the Android build system or not
|
||||
- */
|
||||
- if (opts->avd != NULL)
|
||||
- {
|
||||
- android_avdInfo = avdInfo_new( opts->avd, android_avdParams );
|
||||
- if (android_avdInfo == NULL) {
|
||||
- /* an error message has already been printed */
|
||||
- dprint("could not find virtual device named '%s'", opts->avd);
|
||||
- exit(1);
|
||||
- }
|
||||
- }
|
||||
- else
|
||||
{
|
||||
if (!android_build_out) {
|
||||
android_build_out = android_build_root = opts->sysdir;
|
||||
--- a/android/avd/info.c
|
||||
+++ b/android/avd/info.c
|
||||
@@ -1233,10 +1233,8 @@ _getBuildImagePaths( AvdInfo* i, AvdInf
|
||||
** take care of checking the state
|
||||
**/
|
||||
imageLoader_set ( l, AVD_IMAGE_INITSYSTEM );
|
||||
- imageLoader_load( l, IMAGE_REQUIRED | IMAGE_DONT_LOCK );
|
||||
-
|
||||
- /* force the system image to read-only status */
|
||||
- l->pState[0] = IMAGE_STATE_READONLY;
|
||||
+ l->pState[0] = IMAGE_STATE_MUSTLOCK;
|
||||
+ imageLoader_load( l, IMAGE_REQUIRED );
|
||||
|
||||
/** cache partition handling
|
||||
**/
|
Before Width: | Height: | Size: 3.4 KiB |
Before Width: | Height: | Size: 4.0 KiB |
Before Width: | Height: | Size: 4.0 KiB |
Before Width: | Height: | Size: 3.4 KiB |
Before Width: | Height: | Size: 3.5 KiB |
Before Width: | Height: | Size: 44 KiB |
Before Width: | Height: | Size: 3.5 KiB |
Before Width: | Height: | Size: 3.5 KiB |
Before Width: | Height: | Size: 2.8 KiB |
Before Width: | Height: | Size: 11 KiB |
@ -1,380 +0,0 @@
|
||||
parts {
|
||||
device {
|
||||
background {
|
||||
image device.png
|
||||
}
|
||||
display {
|
||||
width 320
|
||||
height 480
|
||||
x 31
|
||||
y 72
|
||||
}
|
||||
|
||||
buttons {
|
||||
soft-left {
|
||||
image menu.png
|
||||
x 147
|
||||
y 555
|
||||
}
|
||||
home {
|
||||
image home.png
|
||||
x 48
|
||||
y 590
|
||||
}
|
||||
back {
|
||||
image back.png
|
||||
x 286
|
||||
y 590
|
||||
}
|
||||
dpad-up {
|
||||
image arrow_up.png
|
||||
x 140
|
||||
y 595
|
||||
}
|
||||
dpad-down {
|
||||
image arrow_down.png
|
||||
x 140
|
||||
y 656
|
||||
}
|
||||
dpad-left {
|
||||
image arrow_left.png
|
||||
x 111
|
||||
y 598
|
||||
}
|
||||
dpad-right {
|
||||
image arrow_right.png
|
||||
x 222
|
||||
y 598
|
||||
}
|
||||
dpad-center {
|
||||
image select.png
|
||||
x 142
|
||||
y 626
|
||||
}
|
||||
phone-dial {
|
||||
image send.png
|
||||
x 48
|
||||
y 646
|
||||
}
|
||||
phone-hangup {
|
||||
image end.png
|
||||
x 286
|
||||
y 646
|
||||
}
|
||||
|
||||
power {
|
||||
image power.png
|
||||
x -38
|
||||
y 52
|
||||
}
|
||||
|
||||
volume-up {
|
||||
image volume_up.png
|
||||
x 362
|
||||
y 260
|
||||
}
|
||||
|
||||
volume-down {
|
||||
image volume_down.png
|
||||
x 362
|
||||
y 310
|
||||
}
|
||||
}
|
||||
}
|
||||
|
||||
keyboard {
|
||||
background {
|
||||
image keyboard.png
|
||||
}
|
||||
buttons {
|
||||
1 {
|
||||
image key.png
|
||||
x 0
|
||||
y 0
|
||||
}
|
||||
2 {
|
||||
image key.png
|
||||
x 37
|
||||
y 0
|
||||
}
|
||||
3 {
|
||||
image key.png
|
||||
x 74
|
||||
y 0
|
||||
}
|
||||
4 {
|
||||
image key.png
|
||||
x 111
|
||||
y 0
|
||||
}
|
||||
5 {
|
||||
image key.png
|
||||
x 148
|
||||
y 0
|
||||
}
|
||||
6 {
|
||||
image key.png
|
||||
x 185
|
||||
y 0
|
||||
}
|
||||
7 {
|
||||
image key.png
|
||||
x 222
|
||||
y 0
|
||||
}
|
||||
8 {
|
||||
image key.png
|
||||
x 259
|
||||
y 0
|
||||
}
|
||||
9 {
|
||||
image key.png
|
||||
x 296
|
||||
y 0
|
||||
}
|
||||
0 {
|
||||
image key.png
|
||||
x 333
|
||||
y 0
|
||||
}
|
||||
|
||||
q {
|
||||
image key.png
|
||||
x 0
|
||||
y 36
|
||||
}
|
||||
w {
|
||||
image key.png
|
||||
x 37
|
||||
y 36
|
||||
}
|
||||
e {
|
||||
image key.png
|
||||
x 74
|
||||
y 36
|
||||
}
|
||||
r {
|
||||
image key.png
|
||||
x 111
|
||||
y 36
|
||||
}
|
||||
t {
|
||||
image key.png
|
||||
x 148
|
||||
y 36
|
||||
}
|
||||
y {
|
||||
image key.png
|
||||
x 185
|
||||
y 36
|
||||
}
|
||||
u {
|
||||
image key.png
|
||||
x 222
|
||||
y 36
|
||||
}
|
||||
i {
|
||||
image key.png
|
||||
x 259
|
||||
y 36
|
||||
}
|
||||
o {
|
||||
image key.png
|
||||
x 296
|
||||
y 36
|
||||
}
|
||||
p {
|
||||
image key.png
|
||||
x 333
|
||||
y 36
|
||||
}
|
||||
|
||||
a {
|
||||
image key.png
|
||||
x 0
|
||||
y 72
|
||||
}
|
||||
s {
|
||||
image key.png
|
||||
x 37
|
||||
y 72
|
||||
}
|
||||
d {
|
||||
image key.png
|
||||
x 74
|
||||
y 72
|
||||
}
|
||||
f {
|
||||
image key.png
|
||||
x 111
|
||||
y 72
|
||||
}
|
||||
g {
|
||||
image key.png
|
||||
x 148
|
||||
y 72
|
||||
}
|
||||
h {
|
||||
image key.png
|
||||
x 185
|
||||
y 72
|
||||
}
|
||||
j {
|
||||
image key.png
|
||||
x 222
|
||||
y 72
|
||||
}
|
||||
k {
|
||||
image key.png
|
||||
x 259
|
||||
y 72
|
||||
}
|
||||
l {
|
||||
image key.png
|
||||
x 296
|
||||
y 72
|
||||
}
|
||||
DEL {
|
||||
image key.png
|
||||
x 333
|
||||
y 72
|
||||
}
|
||||
|
||||
CAP {
|
||||
image key.png
|
||||
x 0
|
||||
y 108
|
||||
}
|
||||
z {
|
||||
image key.png
|
||||
x 37
|
||||
y 108
|
||||
}
|
||||
x {
|
||||
image key.png
|
||||
x 74
|
||||
y 108
|
||||
}
|
||||
c {
|
||||
image key.png
|
||||
x 111
|
||||
y 108
|
||||
}
|
||||
v {
|
||||
image key.png
|
||||
x 148
|
||||
y 108
|
||||
}
|
||||
b {
|
||||
image key.png
|
||||
x 185
|
||||
y 108
|
||||
}
|
||||
n {
|
||||
image key.png
|
||||
x 222
|
||||
y 108
|
||||
}
|
||||
m {
|
||||
image key.png
|
||||
x 259
|
||||
y 108
|
||||
}
|
||||
PERIOD {
|
||||
image key.png
|
||||
x 296
|
||||
y 108
|
||||
}
|
||||
ENTER {
|
||||
image key.png
|
||||
x 333
|
||||
y 108
|
||||
}
|
||||
|
||||
ALT {
|
||||
image key.png
|
||||
x 0
|
||||
y 144
|
||||
}
|
||||
SYM {
|
||||
image key.png
|
||||
x 37
|
||||
y 144
|
||||
}
|
||||
AT {
|
||||
image key.png
|
||||
x 74
|
||||
y 144
|
||||
}
|
||||
SPACE {
|
||||
image spacebar.png
|
||||
x 111
|
||||
y 144
|
||||
}
|
||||
SLASH {
|
||||
image key.png
|
||||
x 259
|
||||
y 144
|
||||
}
|
||||
COMMA {
|
||||
image key.png
|
||||
x 296
|
||||
y 144
|
||||
}
|
||||
ALT2 {
|
||||
image key.png
|
||||
x 333
|
||||
y 144
|
||||
}
|
||||
|
||||
}
|
||||
}
|
||||
}
|
||||
|
||||
layouts {
|
||||
portrait {
|
||||
width 900
|
||||
height 730
|
||||
color 0xe0e0e0
|
||||
event EV_SW:0:1
|
||||
|
||||
part1 {
|
||||
name device
|
||||
x 40
|
||||
y -18
|
||||
}
|
||||
part2 {
|
||||
name keyboard
|
||||
x 480
|
||||
y 200
|
||||
}
|
||||
}
|
||||
|
||||
landscape {
|
||||
width 900
|
||||
height 670
|
||||
color 0xe0e0e0
|
||||
event EV_SW:0:0
|
||||
|
||||
part1 {
|
||||
name device
|
||||
x 50
|
||||
y 440
|
||||
rotation 3
|
||||
}
|
||||
part2 {
|
||||
name keyboard
|
||||
x 250
|
||||
y 470
|
||||
}
|
||||
}
|
||||
}
|
||||
|
||||
keyboard {
|
||||
charmap qwerty2
|
||||
}
|
||||
|
||||
network {
|
||||
speed full
|
||||
delay none
|
||||
}
|
Before Width: | Height: | Size: 3.0 KiB |
Before Width: | Height: | Size: 3.7 KiB |
Before Width: | Height: | Size: 3.3 KiB |
Before Width: | Height: | Size: 3.5 KiB |
Before Width: | Height: | Size: 2.8 KiB |
Before Width: | Height: | Size: 3.5 KiB |
Before Width: | Height: | Size: 3.8 KiB |