mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 12:33:08 +02:00
add glib
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@535 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c2ba34acd7
commit
e797da86ca
@ -40,6 +40,7 @@ source "package/fping/Config.in"
|
||||
|
||||
comment "Libraries"
|
||||
source "package/zlib/Config.in"
|
||||
source "package/glib/Config.in"
|
||||
source "package/gmp/Config.in"
|
||||
source "package/libpcap/Config.in"
|
||||
source "package/libelf/Config.in"
|
||||
|
@ -13,6 +13,7 @@ package-$(BR2_PACKAGE_DNSMASQ) += dnsmasq
|
||||
package-$(BR2_PACKAGE_EBTABLES) += ebtables
|
||||
package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
|
||||
package-$(BR2_PACKAGE_FPING) += fping
|
||||
package-$(BR2_PACKAGE_GLIB) += glib
|
||||
package-$(BR2_PACKAGE_GMP) += gmp
|
||||
package-$(BR2_PACKAGE_HASERL) += haserl
|
||||
package-$(BR2_PACKAGE_IPTABLES) += iptables
|
||||
|
6
openwrt/package/glib/Config.in
Normal file
6
openwrt/package/glib/Config.in
Normal file
@ -0,0 +1,6 @@
|
||||
config BR2_PACKAGE_GLIB
|
||||
tristate "glib 1.2"
|
||||
default m
|
||||
help
|
||||
GLib is a library containing many useful C routines for things such
|
||||
as trees, hashes, and lists.
|
104
openwrt/package/glib/Makefile
Normal file
104
openwrt/package/glib/Makefile
Normal file
@ -0,0 +1,104 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME := glib
|
||||
PKG_VERSION := 1.2.10
|
||||
PKG_RELEASE := 1
|
||||
PKG_MD5SUM := 6fe30dad87c77b91b632def29dd69ef9
|
||||
|
||||
PKG_SOURCE_SITE := ftp://ftp.gtk.org/pub/gtk/v1.2
|
||||
PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_CAT := zcat
|
||||
PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
|
||||
PKG_IPK := $(PACKAGE_DIR)/glib1.2_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
|
||||
|
||||
|
||||
$(DL_DIR)/$(PKG_SOURCE_FILE):
|
||||
mkdir -p $(DL_DIR)
|
||||
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
|
||||
|
||||
$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||
mkdir -p $(TOOL_BUILD_DIR)
|
||||
$(PKG_SOURCE_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||
$(PATCH) $(PKG_BUILD_DIR) ./patches
|
||||
touch $(PKG_BUILD_DIR)/.patched
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.cache config.status; \
|
||||
glib_cv_sizeof_gmutex=24 \
|
||||
ac_cv_sizeof_char=1 \
|
||||
ac_cv_sizeof_short=2 \
|
||||
ac_cv_sizeof_int=4 \
|
||||
ac_cv_sizeof_long=4 \
|
||||
ac_cv_sizeof_long_long=8 \
|
||||
ac_cv_sizeof_void_p=4 \
|
||||
glib_cv_prog_cc_ansi_proto="no" \
|
||||
glib_cv_has__inline="yes" \
|
||||
glib_cv_has__inline__="yes" \
|
||||
glib_cv_hasinline="yes" \
|
||||
glib_cv_sane_realloc="yes" \
|
||||
glib_cv_va_copy="no" \
|
||||
glib_cv___va_copy="yes" \
|
||||
glib_cv_va_val_copy="yes" \
|
||||
glib_cv_rtldglobal_broken="no" \
|
||||
glib_cv_uscore="no" \
|
||||
ac_cv_func_getpwuid_r="yes" \
|
||||
glib_cv_func_pthread_mutex_trylock_posix="yes" \
|
||||
glib_cv_func_pthread_cond_timedwait_posix="yes" \
|
||||
glib_cv_sizeof_gmutex="24" \
|
||||
glib_cv_byte_contents_gmutex="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0" \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--sbindir=/usr/sbin \
|
||||
--libexecdir=/usr/lib \
|
||||
--sysconfdir=/etc \
|
||||
--datadir=/usr/share \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--enable-shared=yes \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
);
|
||||
touch $(PKG_BUILD_DIR)/.configured
|
||||
|
||||
$(PKG_BUILD_DIR)/libglib.so: $(PKG_BUILD_DIR)/.configured
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS)
|
||||
|
||||
$(STAGING_DIR)/lib/libglib.so: $(PKG_BUILD_DIR)/libglib.so
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(STAGING_DIR)" \
|
||||
install
|
||||
|
||||
$(PKG_IPK): $(STAGING_DIR)/lib/libglib.so
|
||||
mkdir -p $(PACKAGE_DIR)
|
||||
$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_BUILD_DIR)/ipkg/glib glib.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
|
||||
mkdir -p $(PKG_BUILD_DIR)/ipkg/glib/usr/lib
|
||||
cp -a $(PKG_BUILD_DIR)/.libs/*.so* $(PKG_BUILD_DIR)/ipkg/glib/usr/lib
|
||||
cp -a $(PKG_BUILD_DIR)/*/.libs/*.so* $(PKG_BUILD_DIR)/ipkg/glib/usr/lib
|
||||
$(STRIP) $(PKG_BUILD_DIR)/ipkg/glib/usr/lib/*
|
||||
$(IPKG_BUILD) $(PKG_BUILD_DIR)/ipkg/glib $(PACKAGE_DIR)
|
||||
|
||||
$(IPKG_STATE_DIR)/info/glib.list: $(PKG_IPK)
|
||||
$(IPKG) install $(PKG_IPK)
|
||||
|
||||
source: $(DL_DIR)/$(PKG_SOURCE_FILE)
|
||||
prepare: $(PKG_BUILD_DIR)/.patched
|
||||
compile: $(STAGING_DIR)/lib/libglib.so $(PKG_IPK)
|
||||
install: $(PKG_ZLIB) $(IPKG_STATE_DIR)/info/glib.list
|
||||
|
||||
clean:
|
||||
rm -rf $(PKG_BUILD_DIR)
|
||||
rm -f $(STAGING_DIR)/lib/libglib* $(STAGING_DIR)/include/glib*
|
||||
rm -f $(PACKAGE_DIR)/glib\*.ipk
|
||||
|
8
openwrt/package/glib/glib.control
Normal file
8
openwrt/package/glib/glib.control
Normal file
@ -0,0 +1,8 @@
|
||||
Package: glib1
|
||||
Priority: optional
|
||||
Section: libs
|
||||
Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
|
||||
Source: buildroot internal
|
||||
Description: The GLib library of C routines
|
||||
GLib is a library containing many useful C routines for things such
|
||||
as trees, hashes, and lists.
|
19004
openwrt/package/glib/patches/01-debian-9
Normal file
19004
openwrt/package/glib/patches/01-debian-9
Normal file
File diff suppressed because it is too large
Load Diff
210
openwrt/package/glib/patches/02-cross-compile-fix.patch
Normal file
210
openwrt/package/glib/patches/02-cross-compile-fix.patch
Normal file
@ -0,0 +1,210 @@
|
||||
diff -urN glib-1.2.10.old/configure glib-1.2.10/configure
|
||||
--- glib-1.2.10.old/configure 2005-04-03 01:09:18.000000000 +0200
|
||||
+++ glib-1.2.10/configure 2005-04-03 01:09:37.000000000 +0200
|
||||
@@ -6025,7 +6025,7 @@
|
||||
glib_save_LIBS=$LIBS
|
||||
LIBS="$LIBS -lm"
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6032 "configure"
|
||||
@@ -6043,7 +6043,7 @@
|
||||
glib_save_CFLAGS=$CFLAGS
|
||||
CFLAGS="$CFLAGS -std1"
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6050 "configure"
|
||||
@@ -6390,7 +6390,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6397 "configure"
|
||||
@@ -6430,7 +6430,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6437 "configure"
|
||||
@@ -6470,7 +6470,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6477 "configure"
|
||||
@@ -6510,7 +6510,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6517 "configure"
|
||||
@@ -6550,7 +6550,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6557 "configure"
|
||||
@@ -6590,7 +6590,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6597 "configure"
|
||||
@@ -6708,7 +6708,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6715 "configure"
|
||||
@@ -6749,7 +6749,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6756 "configure"
|
||||
@@ -6790,7 +6790,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6797 "configure"
|
||||
@@ -6876,7 +6876,7 @@
|
||||
rm -f conftest*
|
||||
if test $ac_cv_c_bigendian = unknown; then
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 6883 "configure"
|
||||
@@ -7767,7 +7767,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 7774 "configure"
|
||||
@@ -7809,7 +7809,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 7816 "configure"
|
||||
@@ -7854,7 +7854,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 7861 "configure"
|
||||
@@ -7899,7 +7899,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 7906 "configure"
|
||||
@@ -8254,7 +8254,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 8261 "configure"
|
||||
@@ -8306,7 +8306,7 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 8313 "configure"
|
||||
@@ -9137,7 +9137,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9144 "configure"
|
||||
@@ -9237,7 +9237,7 @@
|
||||
echo "configure:9238: checking whether pthread_mutex_trylock is posix like" >&5
|
||||
# DCE Threads return 1 as success, posix 0. what a mess.
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9244 "configure"
|
||||
@@ -9267,7 +9267,7 @@
|
||||
echo "configure:9268: checking whether pthread_cond_timedwait is posix like" >&5
|
||||
# DCE Threads return -1 as failure, posix ETIMEDOUT.
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9274 "configure"
|
||||
@@ -9332,7 +9332,7 @@
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9339 "configure"
|
||||
@@ -9452,7 +9452,7 @@
|
||||
done
|
||||
echo "return 0; }" >>confrun.c
|
||||
if test "$cross_compiling" = yes; then
|
||||
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
|
||||
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
|
||||
else
|
||||
cat > conftest.$ac_ext <<EOF
|
||||
#line 9459 "configure"
|
31
openwrt/package/glib/patches/03-use-glibconfig-sysdefs
Normal file
31
openwrt/package/glib/patches/03-use-glibconfig-sysdefs
Normal file
@ -0,0 +1,31 @@
|
||||
diff -urN glib-1.2.10.old/glib.h glib-1.2.10/glib.h
|
||||
--- glib-1.2.10.old/glib.h 2001-02-27 04:44:38.000000000 +0100
|
||||
+++ glib-1.2.10/glib.h 2005-04-03 01:43:17.000000000 +0200
|
||||
@@ -63,6 +63,7 @@
|
||||
* exist. The prototype looks like the above, give or take a const,
|
||||
* or size_t.
|
||||
*/
|
||||
+#include <glibconfig-sysdefs.h>
|
||||
#include <glibconfig.h>
|
||||
|
||||
/* include varargs functions for assertment macros
|
||||
diff -urN glib-1.2.10.old/configure glib-1.2.10/configure
|
||||
--- glib-1.2.10.old/configure 2005-04-03 01:43:49.000000000 +0200
|
||||
+++ glib-1.2.10/configure 2005-04-03 01:45:47.000000000 +0200
|
||||
@@ -575,16 +575,6 @@
|
||||
# Save this value here, since automake will set cflags later
|
||||
cflags_set=${CFLAGS+set}
|
||||
|
||||
-# we rewrite this file
|
||||
-rm -f glibconfig-sysdefs.h
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
|
||||
# libtool versioning
|
||||
LT_RELEASE=$GLIB_MAJOR_VERSION.$GLIB_MINOR_VERSION
|
Loading…
Reference in New Issue
Block a user