mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 21:53:08 +02:00
fix pci initialization and add oleg et driver.
connect new linux structure. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1078 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6e4d5403dc
commit
e89df49f6e
@ -34,7 +34,13 @@ config BR2_PACKAGE_KMOD_EBT
|
|||||||
help
|
help
|
||||||
Kernel modules for bridge firewalling
|
Kernel modules for bridge firewalling
|
||||||
|
|
||||||
config BR2_PACKAGE_KMOD_IPT4
|
config BR2_PACKAGE_KMOD_IPTABLES_V4
|
||||||
|
tristate "Basic set of kernel modules for iptables"
|
||||||
|
default y
|
||||||
|
help
|
||||||
|
Kernel modules for IPv4 firewalling
|
||||||
|
|
||||||
|
config BR2_PACKAGE_KMOD_IPTABLES_V4_EXTRA
|
||||||
tristate "Extra modules for iptables"
|
tristate "Extra modules for iptables"
|
||||||
default m
|
default m
|
||||||
help
|
help
|
||||||
@ -46,7 +52,7 @@ config BR2_PACKAGE_KMOD_IPV6
|
|||||||
help
|
help
|
||||||
Kernel modules for IPv6 protocol support
|
Kernel modules for IPv6 protocol support
|
||||||
|
|
||||||
config BR2_PACKAGE_KMOD_IPT6
|
config BR2_PACKAGE_KMOD_IPTABLES_V6
|
||||||
tristate "Kernel modules for ip6tables"
|
tristate "Kernel modules for ip6tables"
|
||||||
default m
|
default m
|
||||||
depends BR2_PACKAGE_KMOD_IPV6
|
depends BR2_PACKAGE_KMOD_IPV6
|
||||||
@ -140,6 +146,18 @@ config BR2_PACKAGE_KMOD_HFSPLUS
|
|||||||
help
|
help
|
||||||
Kernel modules for HFS+ filesystem support
|
Kernel modules for HFS+ filesystem support
|
||||||
|
|
||||||
|
config BR2_PACKAGE_KMOD_LOOP
|
||||||
|
tristate "loop mount support"
|
||||||
|
default m
|
||||||
|
help
|
||||||
|
Kernel module for loop mount support
|
||||||
|
|
||||||
|
config BR2_PACKAGE_KMOD_NBD
|
||||||
|
tristate "network block device"
|
||||||
|
default m
|
||||||
|
help
|
||||||
|
Kernel module for network block device
|
||||||
|
|
||||||
config BR2_PACKAGE_KMOD_LP
|
config BR2_PACKAGE_KMOD_LP
|
||||||
tristate "parallel port and lp support"
|
tristate "parallel port and lp support"
|
||||||
default m
|
default m
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
# $Id$
|
# $Id$
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
include ./linux.mk
|
include ./linux-2.4/linux.mk
|
||||||
include ./linux.config
|
include ./linux-2.4/linux.config
|
||||||
|
|
||||||
PKG_BUILD_DIR := $(BUILD_DIR)/linux-modules
|
PKG_BUILD_DIR := $(BUILD_DIR)/linux-modules
|
||||||
PKG_RELEASE := 1
|
PKG_RELEASE := 1
|
||||||
@ -57,10 +57,19 @@ $(eval $(call KMOD_template,ARPT,arptables,\
|
|||||||
$(eval $(call KMOD_template,EBT,ebtables,\
|
$(eval $(call KMOD_template,EBT,ebtables,\
|
||||||
$(MODULES_DIR)/kernel/net/bridge/netfilter/*.o \
|
$(MODULES_DIR)/kernel/net/bridge/netfilter/*.o \
|
||||||
,CONFIG_BRIDGE_NF_EBTABLES))
|
,CONFIG_BRIDGE_NF_EBTABLES))
|
||||||
$(eval $(call KMOD_template,IPT4,iptables-extra,\
|
$(eval $(call KMOD_template,IPTABLES_V4,iptables,\
|
||||||
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ipt_state.o \
|
||||||
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/iptable_nat.o \
|
||||||
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ip_nat_ftp.o \
|
||||||
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ipt_conntrack.o \
|
||||||
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ip_conntrack.o \
|
||||||
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ip_conntrack_ftp.o \
|
||||||
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ipt_MASQUERADE.o \
|
||||||
|
))
|
||||||
|
$(eval $(call KMOD_template,IPTABLES_V4_EXTRA,iptables-extra,\
|
||||||
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ip*.o \
|
$(MODULES_DIR)/kernel/net/ipv4/netfilter/ip*.o \
|
||||||
))
|
))
|
||||||
$(eval $(call KMOD_template,IPT6,ip6tables,\
|
$(eval $(call KMOD_template,IPTABLES_V6,ip6tables,\
|
||||||
$(MODULES_DIR)/kernel/net/ipv6/netfilter/ip*.o \
|
$(MODULES_DIR)/kernel/net/ipv6/netfilter/ip*.o \
|
||||||
,CONFIG_IP6_NF_IPTABLES))
|
,CONFIG_IP6_NF_IPTABLES))
|
||||||
$(eval $(call KMOD_template,IPV6,ipv6,\
|
$(eval $(call KMOD_template,IPV6,ipv6,\
|
||||||
@ -93,6 +102,12 @@ $(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
|
|||||||
$(eval $(call KMOD_template,USB_PRINTER,usb-printer,\
|
$(eval $(call KMOD_template,USB_PRINTER,usb-printer,\
|
||||||
$(MODULES_DIR)/kernel/drivers/usb/printer.o \
|
$(MODULES_DIR)/kernel/drivers/usb/printer.o \
|
||||||
,CONFIG_USB_PRINTER))
|
,CONFIG_USB_PRINTER))
|
||||||
|
$(eval $(call KMOD_template,LOOP,loop,\
|
||||||
|
$(MODULES_DIR)/kernel/drivers/block/loop.o \
|
||||||
|
,CONFIG_BLK_DEV_LOOP))
|
||||||
|
$(eval $(call KMOD_template,NBD,nbd,\
|
||||||
|
$(MODULES_DIR)/kernel/drivers/block/nbd.o \
|
||||||
|
,CONFIG_BLK_DEV_NBD))
|
||||||
$(eval $(call KMOD_template,LP,lp,\
|
$(eval $(call KMOD_template,LP,lp,\
|
||||||
$(MODULES_DIR)/kernel/drivers/parport/parport.o \
|
$(MODULES_DIR)/kernel/drivers/parport/parport.o \
|
||||||
$(MODULES_DIR)/kernel/drivers/parport/parport_splink.o \
|
$(MODULES_DIR)/kernel/drivers/parport/parport_splink.o \
|
||||||
|
@ -29,7 +29,7 @@ LINUX_SOURCE_DIR=$(LINUX_DIR)-$(LINUX_VERSION)
|
|||||||
LINUX_BINARY_WL_DRIVER=kernel-binary-wl-0.3.tar.gz
|
LINUX_BINARY_WL_DRIVER=kernel-binary-wl-0.3.tar.gz
|
||||||
LINUX_BINARY_WL_MD5SUM=cc45df670bcfb4e74a709b9d7beba636
|
LINUX_BINARY_WL_MD5SUM=cc45df670bcfb4e74a709b9d7beba636
|
||||||
LINUX_ET_DRIVER=kernel-source-et-0.7.tar.gz
|
LINUX_ET_DRIVER=kernel-source-et-0.7.tar.gz
|
||||||
LINUX_ET_MD5SUM=f2277895f52eae26ae37065685507031
|
LINUX_ET_MD5SUM=2d12b6dae78b20c88fee9fb41e88a51b
|
||||||
|
|
||||||
TARGET_MODULES_DIR=$(TARGET_DIR)/lib/modules/$(LINUX_VERSION)
|
TARGET_MODULES_DIR=$(TARGET_DIR)/lib/modules/$(LINUX_VERSION)
|
||||||
|
|
||||||
|
@ -11420,7 +11420,7 @@ diff -Nur linux-2.4.30/arch/mips/bcm947xx/sbmips.c linux-2.4.30-brcm/arch/mips/b
|
|||||||
+}
|
+}
|
||||||
diff -Nur linux-2.4.30/arch/mips/bcm947xx/sbpci.c linux-2.4.30-brcm/arch/mips/bcm947xx/sbpci.c
|
diff -Nur linux-2.4.30/arch/mips/bcm947xx/sbpci.c linux-2.4.30-brcm/arch/mips/bcm947xx/sbpci.c
|
||||||
--- linux-2.4.30/arch/mips/bcm947xx/sbpci.c 1970-01-01 01:00:00.000000000 +0100
|
--- linux-2.4.30/arch/mips/bcm947xx/sbpci.c 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ linux-2.4.30-brcm/arch/mips/bcm947xx/sbpci.c 2005-05-26 01:46:08.000000000 +0200
|
+++ linux-2.4.30-brcm/arch/mips/bcm947xx/sbpci.c 2005-05-26 21:56:08.000000000 +0200
|
||||||
@@ -0,0 +1,569 @@
|
@@ -0,0 +1,569 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Low-Level PCI and SB support for BCM47xx
|
+ * Low-Level PCI and SB support for BCM47xx
|
||||||
@ -11697,11 +11697,12 @@ diff -Nur linux-2.4.30/arch/mips/bcm947xx/sbpci.c linux-2.4.30-brcm/arch/mips/bc
|
|||||||
+ return -1;
|
+ return -1;
|
||||||
+ sb_core_reset(sbh, 0);
|
+ sb_core_reset(sbh, 0);
|
||||||
+
|
+
|
||||||
+ /* In some board, */
|
+ /* In some board,
|
||||||
+ if(nvram_match("boardtype", "bcm94710dev"))
|
+ if(nvram_match("boardtype", "bcm94710dev"))
|
||||||
+ CT4712_WR = 0;
|
+ CT4712_WR = 0;
|
||||||
+ else
|
+ else
|
||||||
+ CT4712_WR = 1;
|
+ CT4712_WR = 1;
|
||||||
|
+ /*
|
||||||
+
|
+
|
||||||
+ boardflags = (uint32) getintvar(NULL, "boardflags");
|
+ boardflags = (uint32) getintvar(NULL, "boardflags");
|
||||||
+
|
+
|
||||||
@ -11715,8 +11716,7 @@ diff -Nur linux-2.4.30/arch/mips/bcm947xx/sbpci.c linux-2.4.30-brcm/arch/mips/bc
|
|||||||
+ */
|
+ */
|
||||||
+ if (((chip == BCM4712_DEVICE_ID) &&
|
+ if (((chip == BCM4712_DEVICE_ID) &&
|
||||||
+ ((chippkg == BCM4712SMALL_PKG_ID) ||
|
+ ((chippkg == BCM4712SMALL_PKG_ID) ||
|
||||||
+ (chippkg == BCM4712MID_PKG_ID))) ||
|
+ (chippkg == BCM4712MID_PKG_ID))) )
|
||||||
+ (boardflags & BFL_NOPCI || CT4712_WR))
|
|
||||||
+ pci_disabled = TRUE;
|
+ pci_disabled = TRUE;
|
||||||
+
|
+
|
||||||
+ /*
|
+ /*
|
||||||
|
Loading…
Reference in New Issue
Block a user