mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 22:34:04 +02:00
tools/mkimage: avoid picking up unrelated /usr/include headers with the same name as internal header files (e.g. image.h), fixes #12232
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33519 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e126bc2385
commit
ecbec42440
@ -18,6 +18,13 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
|||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
define Host/Prepare
|
||||||
|
$(Host/Prepare/Default)
|
||||||
|
rm -f \
|
||||||
|
$(HOST_BUILD_DIR)/include/errno.h \
|
||||||
|
$(HOST_BUILD_DIR)/include/malloc.h
|
||||||
|
endef
|
||||||
|
|
||||||
define Host/Compile
|
define Host/Compile
|
||||||
rm -f $(HOST_BUILD_DIR)/tools/.depend
|
rm -f $(HOST_BUILD_DIR)/tools/.depend
|
||||||
touch $(HOST_BUILD_DIR)/include/config.h
|
touch $(HOST_BUILD_DIR)/include/config.h
|
||||||
|
14
tools/mkimage/patches/040-include_order.patch
Normal file
14
tools/mkimage/patches/040-include_order.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- a/tools/Makefile
|
||||||
|
+++ b/tools/Makefile
|
||||||
|
@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
|
||||||
|
# Use native tools and options
|
||||||
|
# Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
|
||||||
|
#
|
||||||
|
-HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
|
||||||
|
+HOSTCPPFLAGS = -I $(SRCTREE)/include \
|
||||||
|
-idirafter $(OBJTREE)/include2 \
|
||||||
|
- -idirafter $(OBJTREE)/include \
|
||||||
|
+ -I $(OBJTREE)/include \
|
||||||
|
-I $(SRCTREE)/lib/libfdt \
|
||||||
|
-I $(SRCTREE)/tools \
|
||||||
|
-DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \
|
Loading…
Reference in New Issue
Block a user