1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 17:21:38 +03:00

preliminary sibyte support

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3701 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mbm 2006-04-21 23:25:46 +00:00
parent 9445c77d7c
commit ee873a47d6
6 changed files with 1370 additions and 0 deletions

View File

@ -77,6 +77,11 @@ config BR2_LINUX_2_6_X86
Build firmware images for x86 based boards Build firmware images for x86 based boards
(e.g. Soekris net4521 and net4801, PC Engines WRAP...) (e.g. Soekris net4521 and net4801, PC Engines WRAP...)
config BR2_LINUX_2_6_SIBYTE
bool "SiByte [2.6]"
select BR2_mips
select BR2_LINUX_2_6
if CONFIG_DEVEL if CONFIG_DEVEL
config BR2_LINUX_2_6_MIPS64 config BR2_LINUX_2_6_MIPS64

View File

@ -94,3 +94,4 @@ $(eval $(call kernel_template,2.4,ar531x,2_4_AR531X))
$(eval $(call kernel_template,2.6,aruba,2_6_ARUBA)) $(eval $(call kernel_template,2.6,aruba,2_6_ARUBA))
$(eval $(call kernel_template,2.6,au1000,2_6_AU1000)) $(eval $(call kernel_template,2.6,au1000,2_6_AU1000))
$(eval $(call kernel_template,2.6,xscale,2_6_XSCALE)) $(eval $(call kernel_template,2.6,xscale,2_6_XSCALE))
$(eval $(call kernel_template,2.6,sibyte,2_6_SIBYTE))

View File

@ -0,0 +1,19 @@
include $(TOPDIR)/rules.mk
LINUX_VERSION:=2.6.16.4
LINUX_RELEASE:=1
LINUX_KERNEL_MD5SUM:=cb675279c9711237a06ebb8379a4da27
include ../rules.mk
include ./config
include ../generic-$(KERNEL)/modules.mk
include ../kernel.mk
$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
[ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
[ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
@$(CP) config $(LINUX_DIR)/.config
touch $@

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,17 @@
--- linux-2.6.16.4/drivers/char/Kconfig 2006-04-21 14:38:30.000000000 -0700
+++ linux-2.6.16.4/drivers/char/Kconfig 2006-04-21 14:39:29.000000000 -0700
@@ -340,6 +340,14 @@
To compile this driver as a module, choose M here: the
module will be called istallion.
+config SIBYTE_SB1250_DUART
+ bool "Support for BCM1xxx onchip DUART"
+ depends on MIPS && SIBYTE_SB1xxx_SOC=y
+
+config SIBYTE_SB1250_DUART_CONSOLE
+ bool "Console on BCM1xxx DUART"
+ depends on SIBYTE_SB1250_DUART
+
config AU1000_UART
bool "Enable Au1000 UART Support"
depends on SERIAL_NONSTANDARD && MIPS

View File

@ -0,0 +1,17 @@
--- linux-2.6.16.4/arch/mips/sibyte/sb1250/setup.c 2006-04-21 16:16:18.000000000 -0700
+++ linux-2.6.16.4/arch/mips/sibyte/sb1250/setup.c 2006-04-21 16:15:22.000000000 -0700
@@ -140,6 +140,14 @@
periph_rev = 3;
pass_str = "A2";
break;
+ case K_SYS_REVISION_BCM112x_A3:
+ periph_rev = 3;
+ pass_str = "A3";
+ break;
+ case K_SYS_REVISION_BCM112x_A4:
+ periph_rev = 3;
+ pass_str = "A4";
+ break;
default:
prom_printf("Unknown %s rev %x\n", soc_str, soc_pass);
ret = 1;