1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-12-19 01:15:53 +02:00

[pxa]: upgrade to 2.6.37

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26224 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
kaloz 2011-03-18 13:04:02 +00:00
parent 280163622f
commit f2ef1714a6
7 changed files with 47 additions and 36 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2006-2010 OpenWrt.org # Copyright (C) 2006-2011 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
FEATURES:=squashfs FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org> MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
LINUX_VERSION:=2.6.32.32 LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk

View File

@ -78,8 +78,10 @@ CONFIG_INOTIFY=y
CONFIG_IWMMXT=y CONFIG_IWMMXT=y
# CONFIG_LEDS_GPIO is not set # CONFIG_LEDS_GPIO is not set
CONFIG_MAC80211_DEFAULT_PS_VALUE=0 CONFIG_MAC80211_DEFAULT_PS_VALUE=0
# CONFIG_MACH_ARCOM_ZEUS is not set
# CONFIG_MACH_ARMCORE is not set # CONFIG_MACH_ARMCORE is not set
# CONFIG_MACH_BALLOON3 is not set # CONFIG_MACH_BALLOON3 is not set
# CONFIG_MACH_CAPC7117 is not set
# CONFIG_MACH_CM_X300 is not set # CONFIG_MACH_CM_X300 is not set
# CONFIG_MACH_COLIBRI300 is not set # CONFIG_MACH_COLIBRI300 is not set
# CONFIG_MACH_COLIBRI320 is not set # CONFIG_MACH_COLIBRI320 is not set
@ -92,6 +94,7 @@ CONFIG_MACH_GUMSTIX_VERDEX=y
# CONFIG_MACH_H4700 is not set # CONFIG_MACH_H4700 is not set
# CONFIG_MACH_H5000 is not set # CONFIG_MACH_H5000 is not set
# CONFIG_MACH_HIMALAYA is not set # CONFIG_MACH_HIMALAYA is not set
# CONFIG_MACH_ICONTROL is not set
# CONFIG_MACH_INTELMOTE2 is not set # CONFIG_MACH_INTELMOTE2 is not set
# CONFIG_MACH_LITTLETON is not set # CONFIG_MACH_LITTLETON is not set
# CONFIG_MACH_LOGICPD_PXA270 is not set # CONFIG_MACH_LOGICPD_PXA270 is not set
@ -100,15 +103,24 @@ CONFIG_MACH_GUMSTIX_VERDEX=y
# CONFIG_MACH_MIOA701 is not set # CONFIG_MACH_MIOA701 is not set
# CONFIG_MACH_MP900C is not set # CONFIG_MACH_MP900C is not set
# CONFIG_MACH_PCM027 is not set # CONFIG_MACH_PCM027 is not set
# CONFIG_MACH_RAUMFELD_CONNECTOR is not set
# CONFIG_MACH_RAUMFELD_RC is not set
# CONFIG_MACH_RAUMFELD_SPEAKER is not set
# CONFIG_MACH_SAAR is not set # CONFIG_MACH_SAAR is not set
# CONFIG_MACH_STARGATE2 is not set # CONFIG_MACH_STARGATE2 is not set
# CONFIG_MACH_TAVOREVB is not set # CONFIG_MACH_TAVOREVB is not set
# CONFIG_MACH_TAVOREVB3 is not set
# CONFIG_MACH_VPAC270 is not set
# CONFIG_MACH_XCEP is not set # CONFIG_MACH_XCEP is not set
# CONFIG_MACH_ZIPIT2 is not set
# CONFIG_MACH_ZYLONITE is not set # CONFIG_MACH_ZYLONITE is not set
# CONFIG_MACH_ZYLONITE300 is not set
# CONFIG_MACH_ZYLONITE320 is not set
# CONFIG_MFD_T7L66XB is not set # CONFIG_MFD_T7L66XB is not set
CONFIG_MII=m CONFIG_MII=m
CONFIG_MMC_BLOCK=y CONFIG_MMC_BLOCK=y
CONFIG_MMC_PXA=y CONFIG_MMC_PXA=y
# CONFIG_MMC_SDHCI_PXA is not set
CONFIG_MMC=y CONFIG_MMC=y
CONFIG_MTD_CFI_ADV_OPTIONS=y CONFIG_MTD_CFI_ADV_OPTIONS=y
# CONFIG_MTD_CFI_AMDSTD is not set # CONFIG_MTD_CFI_AMDSTD is not set

View File

@ -17,8 +17,8 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
--- a/arch/arm/mach-pxa/Kconfig --- a/arch/arm/mach-pxa/Kconfig
+++ b/arch/arm/mach-pxa/Kconfig +++ b/arch/arm/mach-pxa/Kconfig
@@ -32,23 +32,34 @@ endmenu @@ -116,23 +116,34 @@ config MACH_CAPC7117
endif select PXA3xx
config ARCH_GUMSTIX config ARCH_GUMSTIX
- bool "Gumstix XScale 255 boards" - bool "Gumstix XScale 255 boards"
@ -63,19 +63,19 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
bool "Intel Mote 2 Platform" bool "Intel Mote 2 Platform"
--- a/arch/arm/mach-pxa/Makefile --- a/arch/arm/mach-pxa/Makefile
+++ b/arch/arm/mach-pxa/Makefile +++ b/arch/arm/mach-pxa/Makefile
@@ -25,7 +25,8 @@ obj-$(CONFIG_CPU_PXA320) += pxa320.o @@ -49,7 +49,8 @@ endif
obj-$(CONFIG_CPU_PXA930) += pxa930.o obj-$(CONFIG_MACH_EM_X270) += em-x270.o
obj-$(CONFIG_MACH_CM_X300) += cm-x300.o
# Specific board support obj-$(CONFIG_MACH_CAPC7117) += capc7117.o mxm8x10.o
-obj-$(CONFIG_ARCH_GUMSTIX) += gumstix.o -obj-$(CONFIG_ARCH_GUMSTIX) += gumstix.o
+obj-$(CONFIG_MACH_GUMSTIX_F) += gumstix.o +obj-$(CONFIG_MACH_GUMSTIX_F) += gumstix.o
+obj-$(CONFIG_MACH_GUMSTIX_VERDEX) += gumstix-verdex.o +obj-$(CONFIG_MACH_GUMSTIX_VERDEX) += gumstix-verdex.o
obj-$(CONFIG_GUMSTIX_AM200EPD) += am200epd.o obj-$(CONFIG_GUMSTIX_AM200EPD) += am200epd.o
obj-$(CONFIG_GUMSTIX_AM300EPD) += am300epd.o obj-$(CONFIG_GUMSTIX_AM300EPD) += am300epd.o
obj-$(CONFIG_ARCH_LUBBOCK) += lubbock.o obj-$(CONFIG_MACH_INTELMOTE2) += stargate2.o
--- /dev/null --- /dev/null
+++ b/arch/arm/mach-pxa/gumstix-verdex.c +++ b/arch/arm/mach-pxa/gumstix-verdex.c
@@ -0,0 +1,749 @@ @@ -0,0 +1,747 @@
+/* +/*
+ * linux/arch/arm/mach-pxa/gumstix-verdex.c + * linux/arch/arm/mach-pxa/gumstix-verdex.c
+ * + *
@ -816,9 +816,7 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
+} +}
+ +
+MACHINE_START(GUMSTIX, "Gumstix verdex") +MACHINE_START(GUMSTIX, "Gumstix verdex")
+ .phys_io = 0x40000000,
+ .boot_params = 0xa0000100, /* match u-boot bi_boot_params */ + .boot_params = 0xa0000100, /* match u-boot bi_boot_params */
+ .io_pg_offst = (io_p2v(0x40000000) >> 18) & 0xfffc,
+ .map_io = pxa_map_io, + .map_io = pxa_map_io,
+ .init_irq = pxa27x_init_irq, + .init_irq = pxa27x_init_irq,
+ .timer = &pxa_timer, + .timer = &pxa_timer,

View File

@ -12,7 +12,7 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
--- a/drivers/video/Kconfig --- a/drivers/video/Kconfig
+++ b/drivers/video/Kconfig +++ b/drivers/video/Kconfig
@@ -1772,6 +1772,37 @@ config FB_PXA @@ -1822,6 +1822,37 @@ config FB_PXA
say M here and read <file:Documentation/kbuild/modules.txt>. say M here and read <file:Documentation/kbuild/modules.txt>.
If unsure, say N. If unsure, say N.

View File

@ -23,9 +23,9 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
/* BTRESET - Reset line to Bluetooth module, active low signal. */ /* BTRESET - Reset line to Bluetooth module, active low signal. */
#define GPIO_GUMSTIX_BTRESET 7 #define GPIO_GUMSTIX_BTRESET 7
@@ -28,9 +31,18 @@ has detected a cable insertion; driven l @@ -20,9 +23,18 @@ this moves to GPIO17 and GPIO37. */
/* GPIOx - Connects to USB D+ and used as a pull-up after GPIOn
#else has detected a cable insertion; driven low otherwise. */
+#ifndef CONFIG_MACH_GUMSTIX_VERDEX +#ifndef CONFIG_MACH_GUMSTIX_VERDEX
+ +
@ -39,10 +39,10 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
+ +
+#endif +#endif
+ +
#endif
/* usb state change */ /* usb state change */
@@ -52,48 +64,136 @@ has detected a cable insertion; driven l #define GUMSTIX_USB_INTR_IRQ IRQ_GPIO(GPIO_GUMSTIX_USB_GPIOn)
@@ -42,48 +54,136 @@ has detected a cable insertion; driven l
* ETH_RST provides a hardware reset line to the ethernet chip * ETH_RST provides a hardware reset line to the ethernet chip
* ETH is the IRQ line in from the ethernet chip to the PXA * ETH is the IRQ line in from the ethernet chip to the PXA
*/ */

View File

@ -15,7 +15,7 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
--- a/drivers/net/smsc911x.c --- a/drivers/net/smsc911x.c
+++ b/drivers/net/smsc911x.c +++ b/drivers/net/smsc911x.c
@@ -1181,7 +1181,7 @@ static int smsc911x_open(struct net_devi @@ -1189,7 +1189,7 @@ static int smsc911x_open(struct net_devi
SMSC_WARNING(IFUP, SMSC_WARNING(IFUP,
"Timed out waiting for EEPROM busy bit to clear"); "Timed out waiting for EEPROM busy bit to clear");
@ -24,7 +24,7 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
/* The soft reset above cleared the device's MAC address, /* The soft reset above cleared the device's MAC address,
* restore it from local copy (set in probe) */ * restore it from local copy (set in probe) */
@@ -1193,8 +1193,8 @@ static int smsc911x_open(struct net_devi @@ -1201,8 +1201,8 @@ static int smsc911x_open(struct net_devi
smsc911x_reg_write(pdata, INT_EN, 0); smsc911x_reg_write(pdata, INT_EN, 0);
smsc911x_reg_write(pdata, INT_STS, 0xFFFFFFFF); smsc911x_reg_write(pdata, INT_STS, 0xFFFFFFFF);
@ -35,7 +35,7 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
if (pdata->config.irq_polarity) { if (pdata->config.irq_polarity) {
SMSC_TRACE(IFUP, "irq polarity: active high"); SMSC_TRACE(IFUP, "irq polarity: active high");
@@ -1220,7 +1220,7 @@ static int smsc911x_open(struct net_devi @@ -1228,7 +1228,7 @@ static int smsc911x_open(struct net_devi
temp |= INT_EN_SW_INT_EN_; temp |= INT_EN_SW_INT_EN_;
smsc911x_reg_write(pdata, INT_EN, temp); smsc911x_reg_write(pdata, INT_EN, temp);
@ -44,7 +44,7 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
while (timeout--) { while (timeout--) {
if (pdata->software_irq_signal) if (pdata->software_irq_signal)
break; break;
@@ -1948,6 +1948,38 @@ static int __devexit smsc911x_drv_remove @@ -1946,6 +1946,38 @@ static int __devexit smsc911x_drv_remove
return 0; return 0;
} }
@ -83,7 +83,7 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
static int __devinit smsc911x_drv_probe(struct platform_device *pdev) static int __devinit smsc911x_drv_probe(struct platform_device *pdev)
{ {
struct net_device *dev; struct net_device *dev;
@@ -2081,11 +2113,11 @@ static int __devinit smsc911x_drv_probe( @@ -2082,11 +2114,11 @@ static int __devinit smsc911x_drv_probe(
SMSC_TRACE(PROBE, SMSC_TRACE(PROBE,
"Mac Address is read from LAN911x EEPROM"); "Mac Address is read from LAN911x EEPROM");
} else { } else {

View File

@ -15,26 +15,27 @@ Signed-off-by: Bobby Powers <bobbypowers@gmail.com>
--- a/drivers/pcmcia/Kconfig --- a/drivers/pcmcia/Kconfig
+++ b/drivers/pcmcia/Kconfig +++ b/drivers/pcmcia/Kconfig
@@ -221,7 +221,8 @@ config PCMCIA_PXA2XX @@ -215,7 +215,7 @@ config PCMCIA_PXA2XX
depends on ARM && ARCH_PXA && PCMCIA
depends on (ARCH_LUBBOCK || MACH_MAINSTONE || PXA_SHARPSL \ depends on (ARCH_LUBBOCK || MACH_MAINSTONE || PXA_SHARPSL \
|| MACH_ARMCORE || ARCH_PXA_PALM || TRIZEPS_PCMCIA \ || MACH_ARMCORE || ARCH_PXA_PALM || TRIZEPS_PCMCIA \
- || ARCH_VIPER || ARCH_PXA_ESERIES || MACH_STARGATE2) || ARCOM_PCMCIA || ARCH_PXA_ESERIES || MACH_STARGATE2 \
+ || ARCH_VIPER || ARCH_PXA_ESERIES || MACH_STARGATE2 \ - || MACH_VPAC270 || MACH_BALLOON3)
+ || ARCH_GUMSTIX) + || MACH_VPAC270 || MACH_BALLOON3 || ARCH_GUMSTIX)
select PCMCIA_SOC_COMMON
help help
Say Y here to include support for the PXA2xx PCMCIA controller Say Y here to include support for the PXA2xx PCMCIA controller
--- a/drivers/pcmcia/Makefile --- a/drivers/pcmcia/Makefile
+++ b/drivers/pcmcia/Makefile +++ b/drivers/pcmcia/Makefile
@@ -77,4 +77,7 @@ pxa2xx-obj-$(CONFIG_MACH_PALMLD) += pxa @@ -71,6 +71,9 @@ pxa2xx-obj-$(CONFIG_MACH_STARGATE2) +=
pxa2xx-obj-$(CONFIG_MACH_E740) += pxa2xx_e740.o pxa2xx-obj-$(CONFIG_MACH_VPAC270) += pxa2xx_vpac270.o
pxa2xx-obj-$(CONFIG_MACH_STARGATE2) += pxa2xx_stargate2.o pxa2xx-obj-$(CONFIG_MACH_BALLOON3) += pxa2xx_balloon3.o
+pxa2xx-obj-$(CONFIG_MACH_GUMSTIX_VERDEX) += pxa2xx_cs.o +pxa2xx-obj-$(CONFIG_MACH_GUMSTIX_VERDEX) += pxa2xx_cs.o
+pxa2xx_cs-objs := pxa2xx_gumstix.o +pxa2xx_cs-objs := pxa2xx_gumstix.o
+ +
obj-$(CONFIG_PCMCIA_PXA2XX) += pxa2xx_core.o $(pxa2xx-obj-y) obj-$(CONFIG_PCMCIA_PXA2XX) += pxa2xx_base.o $(pxa2xx-obj-y)
obj-$(CONFIG_PCMCIA_XXS1500) += xxs1500_ss.o
--- /dev/null --- /dev/null
+++ b/drivers/pcmcia/pxa2xx_gumstix.c +++ b/drivers/pcmcia/pxa2xx_gumstix.c
@@ -0,0 +1,194 @@ @@ -0,0 +1,194 @@