mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-20 01:40:39 +02:00
x86: make alix platform patch apply to 3.3
Based on a patch from Philip Prindeville. While at it, also refresh the patches. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30025 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
67afb34982
commit
f4e4e8cad9
@ -19,12 +19,11 @@ index dc5f1d3..a24bf8c 100644
|
|||||||
|
|
||||||
#include <asm/geode.h>
|
#include <asm/geode.h>
|
||||||
|
|
||||||
-static int force = 0;
|
|
||||||
+#define BIOS_SIGNATURE_TINYBIOS 0xf0000
|
+#define BIOS_SIGNATURE_TINYBIOS 0xf0000
|
||||||
+#define BIOS_SIGNATURE_COREBOOT 0x500
|
+#define BIOS_SIGNATURE_COREBOOT 0x500
|
||||||
+#define BIOS_REGION_SIZE 0x10000
|
+#define BIOS_REGION_SIZE 0x10000
|
||||||
+
|
+
|
||||||
+static bool force = 0;
|
static bool force = 0;
|
||||||
module_param(force, bool, 0444);
|
module_param(force, bool, 0444);
|
||||||
/* FIXME: Award bios is not automatically detected as Alix platform */
|
/* FIXME: Award bios is not automatically detected as Alix platform */
|
||||||
MODULE_PARM_DESC(force, "Force detection as ALIX.2/ALIX.3 platform");
|
MODULE_PARM_DESC(force, "Force detection as ALIX.2/ALIX.3 platform");
|
||||||
@ -58,7 +57,7 @@ index dc5f1d3..a24bf8c 100644
|
|||||||
static struct gpio_led alix_leds[] = {
|
static struct gpio_led alix_leds[] = {
|
||||||
{
|
{
|
||||||
.name = "alix:1",
|
.name = "alix:1",
|
||||||
@@ -64,17 +106,22 @@ static struct platform_device alix_leds_
|
@@ -64,17 +98,22 @@ static struct platform_device alix_leds_
|
||||||
.dev.platform_data = &alix_leds_data,
|
.dev.platform_data = &alix_leds_data,
|
||||||
};
|
};
|
||||||
|
|
||||||
@ -83,7 +82,7 @@ index dc5f1d3..a24bf8c 100644
|
|||||||
const char *bios_virt;
|
const char *bios_virt;
|
||||||
const char *scan_end;
|
const char *scan_end;
|
||||||
const char *p;
|
const char *p;
|
||||||
@@ -109,7 +156,8 @@ static int __init alix_present(unsigned
|
@@ -109,7 +148,8 @@ static int __init alix_present(unsigned
|
||||||
*a = '\0';
|
*a = '\0';
|
||||||
|
|
||||||
tail = p + alix_sig_len;
|
tail = p + alix_sig_len;
|
||||||
@ -93,7 +92,7 @@ index dc5f1d3..a24bf8c 100644
|
|||||||
printk(KERN_INFO
|
printk(KERN_INFO
|
||||||
"%s: system is recognized as \"%s\"\n",
|
"%s: system is recognized as \"%s\"\n",
|
||||||
KBUILD_MODNAME, name);
|
KBUILD_MODNAME, name);
|
||||||
@@ -120,6 +169,24 @@ static int __init alix_present(unsigned
|
@@ -120,6 +160,24 @@ static int __init alix_present(unsigned
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -118,7 +117,7 @@ index dc5f1d3..a24bf8c 100644
|
|||||||
static int __init alix_init(void)
|
static int __init alix_init(void)
|
||||||
{
|
{
|
||||||
const char tinybios_sig[] = "PC Engines ALIX.";
|
const char tinybios_sig[] = "PC Engines ALIX.";
|
||||||
@@ -128,8 +197,9 @@ static int __init alix_init(void)
|
@@ -128,8 +186,9 @@ static int __init alix_init(void)
|
||||||
if (!is_geode())
|
if (!is_geode())
|
||||||
return 0;
|
return 0;
|
||||||
|
|
||||||
|
@ -24,11 +24,9 @@ Cc: Andrew Morton <akpm@linux-foundation.org>
|
|||||||
3 files changed, 136 insertions(+), 0 deletions(-)
|
3 files changed, 136 insertions(+), 0 deletions(-)
|
||||||
create mode 100644 arch/x86/platform/geode/geos.c
|
create mode 100644 arch/x86/platform/geode/geos.c
|
||||||
|
|
||||||
diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
|
|
||||||
index 07c3f15..4ee921b 100644
|
|
||||||
--- a/arch/x86/Kconfig
|
--- a/arch/x86/Kconfig
|
||||||
+++ b/arch/x86/Kconfig
|
+++ b/arch/x86/Kconfig
|
||||||
@@ -2168,6 +2168,13 @@ config ALIX
|
@@ -2133,6 +2133,13 @@ config ALIX
|
||||||
|
|
||||||
Note: You have to set alix.force=1 for boards with Award BIOS.
|
Note: You have to set alix.force=1 for boards with Award BIOS.
|
||||||
|
|
||||||
@ -42,16 +40,11 @@ index 07c3f15..4ee921b 100644
|
|||||||
endif # X86_32
|
endif # X86_32
|
||||||
|
|
||||||
config AMD_NB
|
config AMD_NB
|
||||||
diff --git a/arch/x86/platform/geode/Makefile b/arch/x86/platform/geode/Makefile
|
|
||||||
index 07c9cd0..d8ba564 100644
|
|
||||||
--- a/arch/x86/platform/geode/Makefile
|
--- a/arch/x86/platform/geode/Makefile
|
||||||
+++ b/arch/x86/platform/geode/Makefile
|
+++ b/arch/x86/platform/geode/Makefile
|
||||||
@@ -1 +1,2 @@
|
@@ -1 +1,2 @@
|
||||||
obj-$(CONFIG_ALIX) += alix.o
|
obj-$(CONFIG_ALIX) += alix.o
|
||||||
+obj-$(CONFIG_GEOS) += geos.o
|
+obj-$(CONFIG_GEOS) += geos.o
|
||||||
diff --git a/arch/x86/platform/geode/geos.c b/arch/x86/platform/geode/geos.c
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..c2e6d53
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/x86/platform/geode/geos.c
|
+++ b/arch/x86/platform/geode/geos.c
|
||||||
@@ -0,0 +1,128 @@
|
@@ -0,0 +1,128 @@
|
||||||
@ -183,6 +176,3 @@ index 0000000..c2e6d53
|
|||||||
+MODULE_AUTHOR("Philip Prindeville <philipp@redfish-solutions.com>");
|
+MODULE_AUTHOR("Philip Prindeville <philipp@redfish-solutions.com>");
|
||||||
+MODULE_DESCRIPTION("Traverse Technologies Geos System Setup");
|
+MODULE_DESCRIPTION("Traverse Technologies Geos System Setup");
|
||||||
+MODULE_LICENSE("GPL");
|
+MODULE_LICENSE("GPL");
|
||||||
--
|
|
||||||
1.7.7.4
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user