mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-24 01:01:52 +02:00
package/busybox: add upstream udhcp hostname truncation fix, bump release number
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21510 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cf06be1395
commit
f5275883b9
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=busybox
|
PKG_NAME:=busybox
|
||||||
PKG_VERSION:=1.16.1
|
PKG_VERSION:=1.16.1
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
|
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
|
||||||
|
11
package/busybox/patches/000-upstream-dhcpd.patch
Normal file
11
package/busybox/patches/000-upstream-dhcpd.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/networking/udhcp/leases.c
|
||||||
|
+++ b/networking/udhcp/leases.c
|
||||||
|
@@ -64,6 +64,8 @@ struct dyn_lease* FAST_FUNC add_lease(
|
||||||
|
oldest->hostname[0] = '\0';
|
||||||
|
if (hostname) {
|
||||||
|
char *p;
|
||||||
|
+
|
||||||
|
+ hostname_len++; /* include NUL */
|
||||||
|
if (hostname_len > sizeof(oldest->hostname))
|
||||||
|
hostname_len = sizeof(oldest->hostname);
|
||||||
|
p = safe_strncpy(oldest->hostname, hostname, hostname_len);
|
Loading…
Reference in New Issue
Block a user