1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 16:45:05 +03:00

Add ulogd package

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@914 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2005-05-15 21:33:09 +00:00
parent 1e6617a93f
commit f57a147ad8
11 changed files with 179 additions and 0 deletions

View File

@ -67,6 +67,7 @@ source "package/siproxd/Config.in"
source "package/sipsak/Config.in"
source "package/htpdate/Config.in"
source "package/howl/Config.in"
source "package/ulogd/Config.in"
source "package/vsftpd/Config.in"
source "package/xinetd/Config.in"

View File

@ -89,6 +89,7 @@ package-$(BR2_PACKAGE_SIPSAK) += sipsak
package-$(BR2_PACKAGE_HTPDATE) += htpdate
package-$(BR2_PACKAGE_HOWL) += howl
package-$(BR2_PACKAGE_OSIRISD) += osiris
package-$(BR2_PACKAGE_ULOGD) += ulogd
package-$(BR2_PACKAGE_VSFTPD) += vsftpd
package-$(BR2_PACKAGE_XINETD) += xinetd

View File

@ -0,0 +1,20 @@
config BR2_PACKAGE_ULOGD
tristate "ulogd - netfilter userspace logging daemon"
default m if CONFIG_DEVEL
help
The netfilter userspace logging daemon
http://gnumonks.org/projects/ulogd
config BR2_PACKAGE_ULOGD_MYSQL_PLUGIN
depends BR2_PACKAGE_ULOGD
tristate "ulogd-mysql-plugin - an output plugin for logging into a MySQL database"
default m if CONFIG_DEVEL
select BR2_PACKAGE_LIBMYSQLCLIENT
config BR2_PACKAGE_ULOGD_PGSQL_PLUGIN
depends BR2_PACKAGE_ULOGD
tristate "ulogd-pgsql-plugin - an output plugin for logging into a PostgreSQL database"
default m if CONFIG_DEVEL
select BR2_PACKAGE_LIBPQ

View File

@ -0,0 +1,96 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=ulogd
PKG_VERSION:=1.23
PKG_RELEASE:=1
PKG_MD5SUM:=fa3dfcaacf31855626d5b731b04a077f
PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/ulogd/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
ifneq ($(BR2_PACKAGE_ULOGD_MYSQL_PLUGIN),)
ULOGD_MYSQL_OPTION:=--with-mysql=$(STAGING_DIR)/usr
endif
ifneq ($(BR2_PACKAGE_ULOGD_PGSQL_PLUGIN),)
ULOGD_PGSQL_OPTION:=--with-pgsql=$(STAGING_DIR)/usr
endif
define IPKG_plugin_template
$$(IPKG_$(1)):
install -m0755 -d $$(IDIR_$(1))/usr/lib/ulogd
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/ulogd/ulogd_$(2).so $$(IDIR_$(1))/usr/lib/ulogd/
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
endef
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,ULOGD,ulogd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,ULOGD_MYSQL_PLUGIN,ulogd-mysql-plugin,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,ULOGD_PGSQL_PLUGIN,ulogd-pgsql-plugin,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call IPKG_plugin_template,ULOGD_MYSQL_PLUGIN,MYSQL))
$(eval $(call IPKG_plugin_template,ULOGD_PGSQL_PLUGIN,PGSQL))
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
ac_cv_header_pcap_h=no \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
--enable-shared \
--disable-static \
$(ULOGD_MYSQL_OPTION) \
$(ULOGD_PGSQL_OPTION) \
);
touch $(PKG_BUILD_DIR)/.configured
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
install
touch $(PKG_BUILD_DIR)/.built
$(IPKG_ULOGD):
install -d -m0755 $(IDIR_ULOGD)/etc
cp -fpR $(PKG_INSTALL_DIR)/etc/ulogd.conf $(IDIR_ULOGD)/etc/
install -d -m0755 $(IDIR_ULOGD)/etc/default
install -m0644 ./files/ulogd.default $(IDIR_ULOGD)/etc/default/ulogd
install -d -m0755 $(IDIR_ULOGD)/etc/init.d
install -m0755 ./files/ulogd.init $(IDIR_ULOGD)/etc/init.d/ulogd
install -d -m0755 $(IDIR_ULOGD)/usr/sbin
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/ulogd $(IDIR_ULOGD)/usr/sbin/
$(RSTRIP) $(IDIR_ULOGD)
$(IPKG_BUILD) $(IDIR_ULOGD) $(PACKAGE_DIR)

View File

@ -0,0 +1 @@
OPTIONS="-d"

View File

@ -0,0 +1,17 @@
#!/bin/sh
BIN=ulogd
DEFAULT=/etc/default/$BIN
LOG_D=/var/log
[ -f $DEFAULT ] && . $DEFAULT
case $1 in
start)
$BIN $OPTIONS
;;
*)
echo "usage: $0 (start)"
exit 1
esac
exit $?

View File

@ -0,0 +1,9 @@
Package: ulogd-mysql-plugin
Priority: optional
Section: net
Version: [TBDL]
Architecture: [TBDL]
Maintainer: Nico <nthill@free.fr>
Source: http://nthill.free.fr/openwrt/sources/ulogd/
Description: Netfilter userspace logging daemon (MySQL plugin)
Depends: libmysqlclient, ulogd

View File

@ -0,0 +1,9 @@
Package: ulogd-pgsql-plugin
Priority: optional
Section: net
Version: [TBDL]
Architecture: [TBDL]
Maintainer: Nico <nthill@free.fr>
Source: http://nthill.free.fr/openwrt/sources/ulogd/
Description: Netfilter userspace logging daemon (PostgreSQL plugin)
Depends: libpq, ulogd

View File

@ -0,0 +1,2 @@
/etc/default/ulogd
/etc/ulogd.conf

View File

@ -0,0 +1,8 @@
Package: ulogd
Priority: optional
Section: net
Version: [TBDL]
Architecture: [TBDL]
Maintainer: Nico <nthill@free.fr>
Source: http://nthill.free.fr/openwrt/sources/ulogd/
Description: Netfilter userspace logging daemon

View File

@ -0,0 +1,15 @@
--- ulogd-1.23/pcap/Makefile.in.orig 2004-03-23 23:36:04.000000000 +0100
+++ ulogd-1.23/pcap/Makefile.in 2005-05-16 00:14:13.000000000 +0200
@@ -14,10 +14,10 @@
distrib:
$(SHARED_LIBS): %.so: %_sh.o
- $(LD) -shared -o $@ $< -lc -lpcap
+ $(LD) -shared $(PCAP_LDFLAGS) -o $@ $< -lc -lpcap
%_sh.o: %.c
- $(CC) $(SH_CFLAGS) -o $@ -c $<
+ $(CC) $(PCAP_CFLAGS) $(SH_CFLAGS) -o $@ -c $<
clean:
$(RM) $(SHARED_LIBS) *.o