mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-12-25 09:33:20 +02:00
fix opkg target arch detection problem on x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14055 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5c74662dcd
commit
f90088e820
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
PKG_NAME:=opkg
|
PKG_NAME:=opkg
|
||||||
PKG_REV:=4564
|
PKG_REV:=4564
|
||||||
PKG_VERSION:=$(PKG_REV)
|
PKG_VERSION:=$(PKG_REV)
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=svn
|
PKG_SOURCE_PROTO:=svn
|
||||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
@ -59,6 +59,7 @@ define Build/Compile
|
|||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
CC="$(TARGET_CC)" \
|
CC="$(TARGET_CC)" \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
HOST_CPU="$(ARCH)" \
|
||||||
all install
|
all install
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
20
package/opkg/patches/004-host_cpu.patch
Normal file
20
package/opkg/patches/004-host_cpu.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- a/libbb/Makefile.am
|
||||||
|
+++ b/libbb/Makefile.am
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
HOST_CPU=@host_cpu@
|
||||||
|
BUILD_CPU=@build_cpu@
|
||||||
|
-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@
|
||||||
|
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@
|
||||||
|
|
||||||
|
noinst_LTLIBRARIES = libbb.la
|
||||||
|
|
||||||
|
--- a/libopkg/Makefile.am
|
||||||
|
+++ b/libopkg/Makefile.am
|
||||||
|
@@ -1,5 +1,6 @@
|
||||||
|
|
||||||
|
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
|
||||||
|
+HOST_CPU=@host_cpu@
|
||||||
|
+AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
|
||||||
|
|
||||||
|
libopkg_includedir=$(includedir)/libopkg
|
||||||
|
libopkg_include_HEADERS= opkg.h
|
Loading…
Reference in New Issue
Block a user