1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-30 01:10:45 +03:00

package/e2fsprogs: disable building of internal lib{blkid,uuid}

Also remove an empty patch.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31702 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2012-05-13 12:20:17 +00:00
parent d9d36efc73
commit fa5df1fabd
3 changed files with 43 additions and 2 deletions

View File

@ -34,8 +34,8 @@ $(call Package/e2fsprogs/Default)
endef
define Package/e2fsprogs/description
This package contains essential ext2 filesystem utilities which consists of
e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2
This package contains essential ext2 filesystem utilities which consists of
e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2
filesystem utilities.
endef
@ -83,6 +83,9 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--enable-elf-shlibs \
--disable-libuuid \
--disable-libblkid \
--disable-uuidd \
--disable-tls \
--disable-nls \
--disable-rpath

View File

@ -0,0 +1,38 @@
--- a/configure
+++ b/configure
@@ -5014,7 +5014,7 @@ if test "${ac_cv_lib_blkid_blkid_get_cac
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lblkid $LIBBLKID $LIBS"
+LIBS="-lblkid $LIBBLKID $LIBUUID $LIBS"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
--- a/misc/Makefile.in
+++ b/misc/Makefile.in
@@ -146,10 +146,10 @@ partinfo: partinfo.o
$(E) " LD $@"
$(Q) $(CC) $(ALL_LDFLAGS) -o partinfo partinfo.o
-e2initrd_helper: e2initrd_helper.o $(DEPLIBS) $(DEPLIBBLKID) $(LIBEXT2FS)
+e2initrd_helper: e2initrd_helper.o $(DEPLIBS) $(DEPLIBBLKID) $(DEPLIBUUID) $(LIBEXT2FS)
$(E) " LD $@"
$(Q) $(CC) $(ALL_LDFLAGS) -o e2initrd_helper e2initrd_helper.o $(LIBS) \
- $(LIBBLKID) $(LIBEXT2FS) $(LIBINTL)
+ $(LIBBLKID) $(LIBUUID) $(LIBEXT2FS) $(LIBINTL)
tune2fs: $(TUNE2FS_OBJS) $(DEPLIBS) $(DEPLIBS_E2P) $(DEPLIBBLKID) \
$(DEPLIBUUID) $(DEPLIBQUOTA) $(LIBEXT2FS)
@@ -289,9 +289,9 @@ dumpe2fs.profiled: $(PROFILED_DUMPE2FS_O
$(PROFILED_DUMPE2FS_OBJS) $(PROFILED_LIBS) \
$(PROFILED_LIBE2P) $(PROFILED_LIBUUID) $(LIBINTL)
-fsck: $(FSCK_OBJS) $(DEPLIBBLKID)
+fsck: $(FSCK_OBJS) $(DEPLIBBLKID) $(DEPLIBUUID)
$(E) " LD $@"
- $(Q) $(CC) $(ALL_LDFLAGS) -o fsck $(FSCK_OBJS) $(LIBBLKID) $(LIBINTL)
+ $(Q) $(CC) $(ALL_LDFLAGS) -o fsck $(FSCK_OBJS) $(LIBBLKID) $(LIBUUID) $(LIBINTL)
fsck.profiled: $(PROFILED_FSCK_OBJS) $(PROFILED_DEPLIBBLKID)
$(E) " LD $@"