Index: madwifi-trunk-r3314/ath_hal/Makefile
===================================================================
--- madwifi-trunk-r3314.orig/ath_hal/Makefile	2008-06-07 17:08:42.354855646 +0200
+++ madwifi-trunk-r3314/ath_hal/Makefile	2008-06-07 17:09:03.260046968 +0200
@@ -78,10 +78,11 @@
 quiet_cmd_uudecode = UUDECODE $@
       cmd_uudecode = $(obj)/uudecode -o $@ $<
 
-$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
 ifdef LINUX24
+$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
 	$(Q)$(obj)/uudecode -o $@ $<
 else
+$(obj)/$(TARGET).hal.o: $(HAL)/public/$(TARGET).hal.o.uu $(obj)/uudecode
 	$(call if_changed,uudecode)
 endif