diff -urN linux-2.6.19.old/arch/mips/Makefile linux-2.6.19.dev/arch/mips/Makefile
--- linux-2.6.19.old/arch/mips/Makefile	2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.dev/arch/mips/Makefile	2006-12-14 03:13:55.000000000 +0100
@@ -600,6 +600,9 @@
 core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/tx4938/common/
 load-$(CONFIG_TOSHIBA_RBTX4938) += 0xffffffff80100000
 
+# temporary until string.h is fixed
+cflags-y += -ffreestanding
+
 cflags-y			+= -Iinclude/asm-mips/mach-generic
 drivers-$(CONFIG_PCI)		+= arch/mips/pci/