#!/bin/sh -e
## 001_ld_makefile_patch.dpatch
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Description: correct where ld scripts are installed
## DP: Author: Chris Chimelis <chris@debian.org>
## DP: Upstream status: N/A
## DP: Date: ??

if [ $# -ne 1 ]; then
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
    exit 1
fi

[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"

case "$1" in
       -patch) patch $patch_opts -p1 < $0;;
       -unpatch) patch $patch_opts -p1 -R < $0;;
        *)
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
                exit 1;;
esac

exit 0

@DPATCH@
Index: binutils-2.18/ld/Makefile.am
===================================================================
--- binutils-2.18.orig/ld/Makefile.am	2007-06-28 09:19:34.837940280 +0200
+++ binutils-2.18/ld/Makefile.am	2007-06-28 09:19:35.795794664 +0200
@@ -18,7 +18,7 @@
 # We put the scripts in the directory $(scriptdir)/ldscripts.
 # We can't put the scripts in $(datadir) because the SEARCH_DIR
 # directives need to be different for native and cross linkers.
-scriptdir = $(tooldir)/lib
+scriptdir = $(libdir)

 EMUL = @EMUL@
 EMULATION_OFILES = @EMULATION_OFILES@
Index: binutils-2.18/ld/Makefile.in
===================================================================
--- binutils-2.18.orig/ld/Makefile.in	2007-06-28 09:19:34.844939216 +0200
+++ binutils-2.18/ld/Makefile.in	2007-06-28 09:19:35.796794512 +0200
@@ -287,7 +287,7 @@
 # We put the scripts in the directory $(scriptdir)/ldscripts.
 # We can't put the scripts in $(datadir) because the SEARCH_DIR
 # directives need to be different for native and cross linkers.
-scriptdir = $(tooldir)/lib
+scriptdir = $(libdir)
 BASEDIR = $(srcdir)/..
 BFDDIR = $(BASEDIR)/bfd
 INCDIR = $(BASEDIR)/include