--- a/Makefile.rules
+++ b/Makefile.rules
@@ -618,16 +618,6 @@ ifdef UNIVERSAL
 
   # Building universal cannot compute dependencies automatically.
   DISABLE_AUTO_DEPENDENCIES=1
-else
-  ifeq ($(TARGET_OS),Darwin)
-    ifeq ($(ARCH),x86_64)
-      TargetCommonOpts = -m64
-    else
-      ifeq ($(ARCH),x86)
-        TargetCommonOpts = -m32
-      endif
-    endif
-  endif
 endif
 
 ifeq ($(HOST_OS),SunOS)