1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 19:52:04 +03:00
openwrt-xburst/target/linux/ifxmips/patches-2.6.30/160-led.patch
blogic 9d03573661 ifxmips: move header files, split up patches, rename some files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18010 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-10-08 22:24:49 +00:00

30 lines
1.1 KiB
Diff

Index: linux-2.6.30.5/drivers/leds/Kconfig
===================================================================
--- linux-2.6.30.5.orig/drivers/leds/Kconfig 2009-09-02 18:22:49.000000000 +0200
+++ linux-2.6.30.5/drivers/leds/Kconfig 2009-09-02 18:29:51.000000000 +0200
@@ -227,6 +227,12 @@
This option enables support for BD2802GU RGB LED driver chips
accessed via the I2C bus.
+config LEDS_IFXMIPS
+ tristate "LED Support for IFXMIPS LEDs"
+ depends on LEDS_CLASS && IFXMIPS
+ help
+ This option enables support for the CM-X270 LEDs.
+
comment "LED Triggers"
config LEDS_TRIGGERS
Index: linux-2.6.30.5/drivers/leds/Makefile
===================================================================
--- linux-2.6.30.5.orig/drivers/leds/Makefile 2009-09-02 18:22:49.000000000 +0200
+++ linux-2.6.30.5/drivers/leds/Makefile 2009-09-02 18:31:23.000000000 +0200
@@ -27,6 +27,7 @@
obj-$(CONFIG_LEDS_DA903X) += leds-da903x.o
obj-$(CONFIG_LEDS_WM8350) += leds-wm8350.o
obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
+obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
# LED SPI Drivers
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o