1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 19:57:09 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/009-adm5120_leds_switch_trigger.patch
juhosg 007000ead9 [adm5120] refresh .23 kernel paches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10366 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-02-03 05:15:25 +00:00

27 lines
1.1 KiB
Diff

Index: linux-2.6.23.14/drivers/leds/Kconfig
===================================================================
--- linux-2.6.23.14.orig/drivers/leds/Kconfig
+++ linux-2.6.23.14/drivers/leds/Kconfig
@@ -165,4 +165,12 @@ config LEDS_TRIGGER_DEFAULT_ON
This allows LEDs to be initialised in the ON state.
If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && LEDS_ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
Index: linux-2.6.23.14/drivers/leds/Makefile
===================================================================
--- linux-2.6.23.14.orig/drivers/leds/Makefile
+++ linux-2.6.23.14/drivers/leds/Makefile
@@ -26,3 +26,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o