mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:30:16 +02:00
e9d9a847eb
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22042 3c298f89-4303-0410-b956-a3cf2f4a3e73
40 lines
1016 B
Diff
40 lines
1016 B
Diff
Patches from: Bill Gatliff <bgat@billgatliff.com>
|
|
Based on:
|
|
* Expunge old Atmel PWMC driver, replacing it with one that conforms to the PWM API
|
|
* Incorporate PWM API code into KBuild
|
|
Ignore the LEDS part atm
|
|
---
|
|
|
|
--- a/drivers/misc/Makefile
|
|
+++ b/drivers/misc/Makefile
|
|
@@ -5,7 +5,6 @@
|
|
obj-$(CONFIG_IBM_ASM) += ibmasm/
|
|
obj-$(CONFIG_HDPU_FEATURES) += hdpuftrs/
|
|
obj-$(CONFIG_AD525X_DPOT) += ad525x_dpot.o
|
|
-obj-$(CONFIG_ATMEL_PWM) += atmel_pwm.o
|
|
obj-$(CONFIG_ATMEL_SSC) += atmel-ssc.o
|
|
obj-$(CONFIG_ATMEL_TCLIB) += atmel_tclib.o
|
|
obj-$(CONFIG_ICS932S401) += ics932s401.o
|
|
--- a/drivers/Kconfig
|
|
+++ b/drivers/Kconfig
|
|
@@ -54,6 +54,8 @@ source "drivers/pps/Kconfig"
|
|
|
|
source "drivers/gpio/Kconfig"
|
|
|
|
+source "drivers/pwm/Kconfig"
|
|
+
|
|
source "drivers/w1/Kconfig"
|
|
|
|
source "drivers/power/Kconfig"
|
|
--- a/drivers/Makefile
|
|
+++ b/drivers/Makefile
|
|
@@ -6,6 +6,8 @@
|
|
#
|
|
|
|
obj-y += gpio/
|
|
+obj-$(CONFIG_GENERIC_PWM) += pwm/
|
|
+
|
|
obj-$(CONFIG_PCI) += pci/
|
|
obj-$(CONFIG_PARISC) += parisc/
|
|
obj-$(CONFIG_RAPIDIO) += rapidio/
|