mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:25:20 +02:00
318c9e430b
There is an error in the unlzma system in the kernel. A lzma compressed squashfs filesystem does not work for me. This should compile and works for me on my Asus WL-500GP, please test it on more systems. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16441 3c298f89-4303-0410-b956-a3cf2f4a3e73
26 lines
908 B
Diff
26 lines
908 B
Diff
--- a/drivers/mtd/maps/Kconfig
|
|
+++ b/drivers/mtd/maps/Kconfig
|
|
@@ -343,6 +343,12 @@ config MTD_CFI_FLAGADM
|
|
Mapping for the Flaga digital module. If you don't have one, ignore
|
|
this setting.
|
|
|
|
+config MTD_BCM47XX
|
|
+ tristate "BCM47xx flash device"
|
|
+ depends on MIPS && MTD_CFI && BCM47XX
|
|
+ help
|
|
+ Support for the flash chips on the BCM947xx board.
|
|
+
|
|
config MTD_REDWOOD
|
|
tristate "CFI Flash devices mapped on IBM Redwood"
|
|
depends on MTD_CFI && ( REDWOOD_4 || REDWOOD_5 || REDWOOD_6 )
|
|
--- a/drivers/mtd/maps/Makefile
|
|
+++ b/drivers/mtd/maps/Makefile
|
|
@@ -29,6 +29,7 @@ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcm
|
|
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
|
|
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
|
|
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
|
|
+obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
|
|
obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
|
|
obj-$(CONFIG_MTD_IPAQ) += ipaq-flash.o
|
|
obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o
|