1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-21 16:19:00 +03:00
openwrt-xburst/target/linux/s3c24xx/patches-2.6.30/055-gta02-leds.patch
lars f6b1fead58 [s3c24xx] The gta02 vibrator driver is not meant to be build as module.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17123 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-08-04 11:12:02 +00:00

26 lines
786 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -227,6 +227,12 @@ config LEDS_BD2802
This option enables support for BD2802GU RGB LED driver chips
accessed via the I2C bus.
+config LEDS_GTA02_VIBRATOR
+ boolean "Vibrator Support for the Openmoko Freerunner GSM phone"
+ depends on LEDS_CLASS && MACH_NEO1973_GTA02
+ help
+ This option enables support for the vibrator on the Openmoko Freerunner.
+
comment "LED Triggers"
config LEDS_TRIGGERS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -30,6 +30,7 @@ obj-$(CONFIG_LEDS_PWM) += leds-pwm.o
# LED SPI Drivers
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
+obj-$(CONFIG_LEDS_GTA02_VIBRATOR) += leds-gta02-vibrator.o
# LED Triggers
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o