mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:38:26 +02:00
6b4b162100
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29725 3c298f89-4303-0410-b956-a3cf2f4a3e73
24 lines
771 B
Diff
24 lines
771 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -120,6 +120,10 @@ config AR8216_PHY
|
|
tristate "Driver for Atheros AR8216 switches"
|
|
select SWCONFIG
|
|
|
|
+config RTL8306_PHY
|
|
+ tristate "Driver for Realtek RTL8306S switches"
|
|
+ select SWCONFIG
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
|
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
|
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|