mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 21:54:40 +02:00
ac85de1ef4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14448 3c298f89-4303-0410-b956-a3cf2f4a3e73
13 lines
393 B
Diff
13 lines
393 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -508,6 +508,9 @@ CFLAGS += $(call cc-option, -fn
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|