mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:11:51 +02:00
71013384a4
Because sshfs expects character device to be /dev/fuse instead of /dev/misc/fuse, sshfs fails. This patch creates fuse device at /dev/fuse instead, also for compatibility the postinstall script (only executed when manually installed per opkg) creates /dev/misc/fuse added the dcache enabled kernel message to fuse24 Closes #5333 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16447 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
442 B
Diff
12 lines
442 B
Diff
--- a/util/Makefile.in
|
|
+++ b/util/Makefile.in
|
|
@@ -453,7 +453,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
install-exec-hook:
|
|
-chown root $(DESTDIR)$(bindir)/fusermount
|
|
-chmod u+s $(DESTDIR)$(bindir)/fusermount
|
|
- @if test ! -e $(DESTDIR)/dev/fuse; then \
|
|
+ -@if test ! -e $(DESTDIR)/dev/fuse; then \
|
|
$(mkdir_p) $(DESTDIR)/dev; \
|
|
echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229"; \
|
|
mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229; \
|