mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:44:39 +02:00
da1bd2aad6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
814 B
Diff
25 lines
814 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -119,6 +119,11 @@ config RTL8306_PHY
|
|
tristate "Driver for Realtek RTL8306S switches"
|
|
select SWCONFIG
|
|
|
|
+config MICREL_PHY
|
|
+ tristate "Drivers for Micrel/Kendin PHYs"
|
|
+ ---help---
|
|
+ Currently has a driver for the KSZ8041
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -24,6 +24,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
|
|
obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
|
|
obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
|
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
|
+obj-$(CONFIG_MICREL_PHY) += micrel.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|
|
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
|