1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 10:36:20 +03:00
openwrt-xburst/package/vncrepeater/patches/01-uclibcxx_linking.patch
florian 666bde2e89 Update to version 0.12, add a default configuration file, thanks to eatnumber1 !
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3612 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-04-11 08:35:01 +00:00

33 lines
1.1 KiB
Diff

diff -urN vncrepeater-0.12/Makefile vncrepeater-0.12.new/Makefile
--- vncrepeater-0.12/Makefile 2006-03-31 07:40:14.000000000 +0200
+++ vncrepeater-0.12.new/Makefile 2006-04-11 10:26:06.345879104 +0200
@@ -1,21 +1,21 @@
-CFLAGS=-Wall
+CFLAGS=-Wall
repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
- g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
+ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
repeater.o: repeater.cpp
- g++ $(CFLAGS) -c repeater.cpp
+ $(CC) $(CFLAGS) -c repeater.cpp
repeaterproc.o: repeaterproc.cpp
- g++ $(CFLAGS) -c repeaterproc.cpp
+ $(CC) $(CFLAGS) -c repeaterproc.cpp
openbsd_stringfuncs.o: openbsd_stringfuncs.cpp
- g++ $(CFLAGS) -c openbsd_stringfuncs.cpp
+ $(CC) $(CFLAGS) -c openbsd_stringfuncs.cpp
iniparser.o: iniparser.cpp
- g++ $(CFLAGS) -c iniparser.cpp
+ $(CC) $(CFLAGS) -c iniparser.cpp
readini.o: readini.cpp
- g++ $(CFLAGS) -c readini.cpp
+ $(CC) $(CFLAGS) -c readini.cpp
clean:
rm -f *.o repeater