1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-20 22:59:18 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
juhosg 9ce519fcfd adm5120: preliminary 2.6.32 support (closes: #6304)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19005 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-01-02 15:52:34 +00:00

23 lines
830 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -315,4 +315,12 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -42,3 +42,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o