1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 01:09:20 +03:00
openwrt-xburst/target/linux/ramips/patches-2.6.39/103-ethernet.patch
juhosg 3120faed8b ramips: raeth: make debugging messages configurable
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30450 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-02-11 15:12:10 +00:00

30 lines
954 B
Diff

--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -494,6 +494,16 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
+config MIPS_RAMIPS_NET
+ tristate "Ethernet driver for rt288x/rt305x"
+ depends on MIPS_RALINK
+ help
+ This driver supports the etehrnet mac inside the ralink wisocs
+
+config RAMIPS_ETH_DEBUG
+ bool "Enable debug messages in the Ralink ethernet driver"
+ depends on MIPS_RAMIPS_NET
+
config SGI_IOC3_ETH
bool "SGI IOC3 Ethernet"
depends on PCI && SGI_IP27
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -227,6 +227,7 @@ obj-$(CONFIG_KORINA) += korina.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+obj-$(CONFIG_MIPS_RAMIPS_NET) += ramips.o
obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
obj-$(CONFIG_DECLANCE) += declance.o
obj-$(CONFIG_ATARILANCE) += atarilance.o