mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 17:11:34 +02:00
4741579f80
* adds arv4518pw mach support * fixes arv4525pw * make sure all mach names have the same style * move code around git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25075 3c298f89-4303-0410-b956-a3cf2f4a3e73
429 lines
13 KiB
Diff
429 lines
13 KiB
Diff
--- a/arch/mips/include/asm/mach-lantiq/machine.h
|
|
+++ b/arch/mips/include/asm/mach-lantiq/machine.h
|
|
@@ -11,4 +11,13 @@
|
|
LANTIQ_MACH_EASY4010, /* Twinpass evalkit */
|
|
LANTIQ_MACH_EASY50712, /* Danube evalkit */
|
|
LANTIQ_MACH_EASY50812, /* AR9 eval board */
|
|
+
|
|
+ /* Arcadyan */
|
|
+ LANTIQ_MACH_ARV4510PW, /* Wippies Homebox */
|
|
+ LANTIQ_MACH_ARV4518PW, /* Airties WAV-221, SMC-7908A-ISP */
|
|
+ LANTIQ_MACH_ARV4520PW, /* Airties WAV-281, Arcor EasyboxA800 */
|
|
+ LANTIQ_MACH_ARV452CPW, /* Arcor EasyboxA801 */
|
|
+ LANTIQ_MACH_ARV4525PW, /* Speedport W502V */
|
|
+ LANTIQ_MACH_ARV752DPW, /* Arcor easybox a803 */
|
|
+ LANTIQ_MACH_ARV7518PW, /* ASTORIA */
|
|
};
|
|
--- a/arch/mips/lantiq/xway/Kconfig
|
|
+++ b/arch/mips/lantiq/xway/Kconfig
|
|
@@ -14,6 +14,10 @@
|
|
bool "Easy4010"
|
|
default y
|
|
|
|
+config LANTIQ_MACH_ARV45XX
|
|
+ bool "ARV45XX"
|
|
+ default y
|
|
+
|
|
endmenu
|
|
|
|
endif
|
|
--- a/arch/mips/lantiq/xway/Makefile
|
|
+++ b/arch/mips/lantiq/xway/Makefile
|
|
@@ -3,3 +3,4 @@
|
|
obj-$(CONFIG_LANTIQ_MACH_EASY50812) += mach-easy50812.o
|
|
obj-$(CONFIG_LANTIQ_MACH_EASY50712) += mach-easy50712.o
|
|
obj-$(CONFIG_LANTIQ_MACH_EASY4010) += mach-easy4010.o
|
|
+obj-$(CONFIG_LANTIQ_MACH_ARV45XX) += mach-arv45xx.o
|
|
--- /dev/null
|
|
+++ b/arch/mips/lantiq/xway/mach-arv45xx.c
|
|
@@ -0,0 +1,389 @@
|
|
+/*
|
|
+ * This program is free software; you can redistribute it and/or modify it
|
|
+ * under the terms of the GNU General Public License version 2 as published
|
|
+ * by the Free Software Foundation.
|
|
+ *
|
|
+ * Copyright (C) 2010 John Crispin <blogic@openwrt.org>
|
|
+ */
|
|
+
|
|
+#include <linux/init.h>
|
|
+#include <linux/platform_device.h>
|
|
+#include <linux/leds.h>
|
|
+#include <linux/gpio.h>
|
|
+#include <linux/gpio_buttons.h>
|
|
+#include <linux/mtd/mtd.h>
|
|
+#include <linux/mtd/partitions.h>
|
|
+#include <linux/mtd/physmap.h>
|
|
+#include <linux/input.h>
|
|
+#include <linux/etherdevice.h>
|
|
+
|
|
+#include <machine.h>
|
|
+
|
|
+#include <xway.h>
|
|
+#include <lantiq_platform.h>
|
|
+
|
|
+#include "devices.h"
|
|
+#include "dev-dwc_otg.h"
|
|
+
|
|
+#define ARV4520PW_LATCH_SWITCH (1 << 10)
|
|
+#define ARV752DPW_LATCH_DEFAULT (2)
|
|
+
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+static struct mtd_partition arv45xx_partitions[] =
|
|
+{
|
|
+ {
|
|
+ .name = "uboot",
|
|
+ .offset = 0x0,
|
|
+ .size = 0x20000,
|
|
+ },
|
|
+ {
|
|
+ .name = "uboot_env",
|
|
+ .offset = 0x20000,
|
|
+ .size = 0x10000,
|
|
+ },
|
|
+ {
|
|
+ .name = "linux",
|
|
+ .offset = 0x30000,
|
|
+ .size = 0x3c0000,
|
|
+ },
|
|
+ {
|
|
+ .name = "board_config",
|
|
+ .offset = 0x3f0000,
|
|
+ .size = 0x10000,
|
|
+ },
|
|
+};
|
|
+
|
|
+static struct mtd_partition arv4518_partitions[] =
|
|
+{
|
|
+ {
|
|
+ .name = "uboot",
|
|
+ .offset = 0x0,
|
|
+ .size = 0x40000,
|
|
+ },
|
|
+ {
|
|
+ .name = "uboot_env",
|
|
+ .offset = 0x40000,
|
|
+ .size = 0x10000,
|
|
+ },
|
|
+ {
|
|
+ .name = "linux",
|
|
+ .offset = 0x50000,
|
|
+ .size = 0x3a0000,
|
|
+ },
|
|
+ {
|
|
+ .name = "board_config",
|
|
+ .offset = 0x3f0000,
|
|
+ .size = 0x10000,
|
|
+ },
|
|
+};
|
|
+
|
|
+static struct mtd_partition arv75xx_partitions[] =
|
|
+{
|
|
+ {
|
|
+ .name = "uboot",
|
|
+ .offset = 0x0,
|
|
+ .size = 0x40000,
|
|
+ },
|
|
+ {
|
|
+ .name = "uboot_env",
|
|
+ .offset = 0x40000,
|
|
+ .size = 0x10000,
|
|
+ },
|
|
+ {
|
|
+ .name = "linux",
|
|
+ .offset = 0x50000,
|
|
+ .size = 0x7a0000,
|
|
+ },
|
|
+ {
|
|
+ .name = "board_config",
|
|
+ .offset = 0x7f0000,
|
|
+ .size = 0x10000,
|
|
+ },
|
|
+};
|
|
+
|
|
+#endif
|
|
+
|
|
+static struct physmap_flash_data arv45xx_flash_data = {
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+ .nr_parts = ARRAY_SIZE(arv45xx_partitions),
|
|
+ .parts = arv45xx_partitions,
|
|
+#endif
|
|
+};
|
|
+
|
|
+static struct physmap_flash_data arv4518_flash_data = {
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+ .nr_parts = ARRAY_SIZE(arv4518_partitions),
|
|
+ .parts = arv4518_partitions,
|
|
+#endif
|
|
+};
|
|
+
|
|
+static struct physmap_flash_data arv75xx_flash_data = {
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+ .nr_parts = ARRAY_SIZE(arv75xx_partitions),
|
|
+ .parts = arv75xx_partitions,
|
|
+#endif
|
|
+};
|
|
+
|
|
+static struct lq_pci_data lq_pci_data = {
|
|
+ .clock = PCI_CLOCK_EXT,
|
|
+ .gpio = PCI_GNT1 | PCI_REQ1,
|
|
+ .irq = {
|
|
+ [14] = INT_NUM_IM0_IRL0 + 22,
|
|
+ },
|
|
+};
|
|
+
|
|
+static struct lq_eth_data lq_eth_data = {
|
|
+ .mii_mode = REV_MII_MODE,
|
|
+ .mac = "\xff\xff\xff\xff\xff\xff",
|
|
+};
|
|
+
|
|
+static struct gpio_led
|
|
+arv4510pw_leds_gpio[] __initdata = {
|
|
+ { .name = "soc:green:foo", .gpio = 4, .active_low = 1, },
|
|
+};
|
|
+
|
|
+static struct gpio_led
|
|
+arv4518pw_leds_gpio[] __initdata = {
|
|
+ { .name = "soc:green:power", .gpio = 3, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:adsl", .gpio = 4, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:internet", .gpio = 5, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:wlan", .gpio = 6, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:yellow:wps", .gpio = 7, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:red:fail", .gpio = 8, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:usb", .gpio = 19, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:voip", .gpio = 32, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:fxs1", .gpio = 33, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:fxs2", .gpio = 34, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:fxo", .gpio = 35, .active_low = 1, .default_trigger = "default-on" },
|
|
+};
|
|
+
|
|
+static struct gpio_button
|
|
+arv4518pw_gpio_buttons[] __initdata = {
|
|
+ { .desc = "wlan", .type = EV_KEY, .code = BTN_0, .threshold = 3, .gpio = 28, .active_low = 1, },
|
|
+ { .desc = "wps", .type = EV_KEY, .code = BTN_1, .threshold = 3, .gpio = 29, .active_low = 1, },
|
|
+ { .desc = "reset", .type = EV_KEY, .code = BTN_2, .threshold = 3, .gpio = 30, .active_low = 1, },
|
|
+};
|
|
+
|
|
+static struct gpio_led
|
|
+arv4520pw_leds_gpio[] __initdata = {
|
|
+ { .name = "soc:blue:power", .gpio = 3, .active_low = 1, },
|
|
+ { .name = "soc:blue:adsl", .gpio = 4, .active_low = 1, },
|
|
+ { .name = "soc:blue:internet", .gpio = 5, .active_low = 1, },
|
|
+ { .name = "soc:red:power", .gpio = 6, .active_low = 1, },
|
|
+ { .name = "soc:yello:wps", .gpio = 7, .active_low = 1, },
|
|
+ { .name = "soc:red:wps", .gpio = 9, .active_low = 1, },
|
|
+ { .name = "soc:blue:voip", .gpio = 32, .active_low = 1, },
|
|
+ { .name = "soc:blue:fxs1", .gpio = 33, .active_low = 1, },
|
|
+ { .name = "soc:blue:fxs2", .gpio = 34, .active_low = 1, },
|
|
+ { .name = "soc:blue:fxo", .gpio = 35, .active_low = 1, },
|
|
+ { .name = "soc:blue:voice", .gpio = 36, .active_low = 1, },
|
|
+ { .name = "soc:blue:usb", .gpio = 37, .active_low = 1, },
|
|
+ { .name = "soc:blue:wlan", .gpio = 38, .active_low = 1, },
|
|
+};
|
|
+
|
|
+static struct gpio_led
|
|
+arv4525pw_leds_gpio[] __initdata = {
|
|
+ { .name = "soc:green:festnetz", .gpio = 4, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:internet", .gpio = 5, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:dsl", .gpio = 6, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:wlan", .gpio = 8, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:online", .gpio = 9, .active_low = 1, .default_trigger = "default-on" },
|
|
+};
|
|
+
|
|
+static struct gpio_led
|
|
+arv752dpw_leds_gpio[] __initdata = {
|
|
+ { .name = "soc:blue:power", .gpio = 3, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:red:internet", .gpio = 5, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:red:power", .gpio = 6, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:red:wps", .gpio = 8, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:red:fxo", .gpio = 35, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:red:voice", .gpio = 36, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:usb", .gpio = 37, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:wlan", .gpio = 38, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:wlan1", .gpio = 39, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:blue:wlan", .gpio = 40, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:blue:wlan1", .gpio = 41, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:eth1", .gpio = 43, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:eth2", .gpio = 44, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:eth3", .gpio = 45, .active_low = 1, .default_trigger = "default-on" },
|
|
+ { .name = "soc:green:eth4", .gpio = 46, .active_low = 1, .default_trigger = "default-on", },
|
|
+};
|
|
+
|
|
+static struct gpio_button
|
|
+arv752dpw_gpio_buttons[] __initdata = {
|
|
+ { .desc = "btn0", .type = EV_KEY, .code = BTN_0, .threshold = 3, .gpio = 12, .active_low = 1, },
|
|
+ { .desc = "btn1", .type = EV_KEY, .code = BTN_1, .threshold = 3, .gpio = 13, .active_low = 1, },
|
|
+ { .desc = "btn2", .type = EV_KEY, .code = BTN_2, .threshold = 3, .gpio = 28, .active_low = 1, },
|
|
+};
|
|
+
|
|
+static struct gpio_led
|
|
+arv7518pw_leds_gpio[] __initdata = {
|
|
+ { .name = "soc:green:power", .gpio = 2, .active_low = 1, },
|
|
+ { .name = "soc:green:adsl", .gpio = 4, .active_low = 1, },
|
|
+ { .name = "soc:green:internet", .gpio = 5, .active_low = 1, },
|
|
+ { .name = "soc:green:wlan", .gpio = 6, .active_low = 1, },
|
|
+ { .name = "sco:red:internet", .gpio = 8, .active_low = 1, },
|
|
+ { .name = "soc:green:usb", .gpio = 19, .active_low = 1, },
|
|
+};
|
|
+
|
|
+static void
|
|
+arv45xx_register_ethernet(void)
|
|
+{
|
|
+#define ARV45XX_BRN_MAC 0x3f0016
|
|
+ memcpy_fromio(lq_eth_data.mac,
|
|
+ (void *)KSEG1ADDR(LQ_FLASH_START + ARV45XX_BRN_MAC), 6);
|
|
+ lq_register_ethernet(&lq_eth_data);
|
|
+}
|
|
+
|
|
+static void
|
|
+arv75xx_register_ethernet(void)
|
|
+{
|
|
+#define ARV75XX_BRN_MAC 0x7f0016
|
|
+ memcpy_fromio(lq_eth_data.mac,
|
|
+ (void *)KSEG1ADDR(LQ_FLASH_START + ARV75XX_BRN_MAC), 6);
|
|
+ lq_register_ethernet(&lq_eth_data);
|
|
+}
|
|
+
|
|
+static void
|
|
+bewan_register_ethernet(void)
|
|
+{
|
|
+#define BEWAN_BRN_MAC 0x3f0014
|
|
+ memcpy_fromio(lq_eth_data.mac,
|
|
+ (void *)KSEG1ADDR(LQ_FLASH_START + BEWAN_BRN_MAC), 6);
|
|
+ lq_register_ethernet(&lq_eth_data);
|
|
+}
|
|
+
|
|
+static void __init
|
|
+arv4510pw_init(void)
|
|
+{
|
|
+ lq_register_gpio();
|
|
+ lq_register_gpio_stp();
|
|
+ lq_register_gpio_leds(arv4510pw_leds_gpio, ARRAY_SIZE(arv4510pw_leds_gpio));
|
|
+ lq_register_asc(0);
|
|
+ lq_register_asc(1);
|
|
+ lq_register_nor(&arv45xx_flash_data);
|
|
+ lq_register_pci(&lq_pci_data);
|
|
+ lq_pci_data.irq[15] = (INT_NUM_IM2_IRL0 + 31);
|
|
+ lq_pci_data.gpio |= PCI_EXIN1 | PCI_REQ2;
|
|
+ lq_register_pci(&lq_pci_data);
|
|
+ lq_register_wdt();
|
|
+ bewan_register_ethernet();
|
|
+}
|
|
+
|
|
+MIPS_MACHINE(LANTIQ_MACH_ARV4510PW,
|
|
+ "ARV4510PW",
|
|
+ "ARV4510PW - Wippies Homebox",
|
|
+ arv4510pw_init);
|
|
+
|
|
+static void __init
|
|
+arv4518pw_init(void)
|
|
+{
|
|
+ lq_register_gpio();
|
|
+ lq_register_gpio_ebu(0);
|
|
+ lq_register_gpio_leds(arv4518pw_leds_gpio, ARRAY_SIZE(arv4518pw_leds_gpio));
|
|
+ lq_register_gpio_buttons(arv4518pw_gpio_buttons, ARRAY_SIZE(arv4518pw_gpio_buttons));
|
|
+ lq_register_asc(0);
|
|
+ lq_register_asc(1);
|
|
+ lq_register_nor(&arv4518_flash_data);
|
|
+ lq_pci_data.gpio = PCI_GNT2 | PCI_REQ2;
|
|
+ lq_register_pci(&lq_pci_data);
|
|
+ lq_register_wdt();
|
|
+ arv45xx_register_ethernet();
|
|
+ xway_register_dwc(14);
|
|
+ gpio_request(13, "switch-reset");
|
|
+ gpio_direction_output(13, 1);
|
|
+ gpio_export(13, 0);
|
|
+}
|
|
+
|
|
+MIPS_MACHINE(LANTIQ_MACH_ARV4518PW,
|
|
+ "ARV4518PW",
|
|
+ "ARV4518PW - SMC7908A-ISP, Airties WAV-221",
|
|
+ arv4518pw_init);
|
|
+
|
|
+static void __init
|
|
+arv4520pw_init(void)
|
|
+{
|
|
+ lq_register_gpio();
|
|
+ lq_register_gpio_ebu(ARV4520PW_LATCH_SWITCH);
|
|
+ lq_register_gpio_leds(arv4520pw_leds_gpio, ARRAY_SIZE(arv4520pw_leds_gpio));
|
|
+ lq_register_asc(0);
|
|
+ lq_register_asc(1);
|
|
+ lq_register_nor(&arv45xx_flash_data);
|
|
+ lq_register_pci(&lq_pci_data);
|
|
+ lq_register_wdt();
|
|
+ arv45xx_register_ethernet();
|
|
+ xway_register_dwc(28);
|
|
+}
|
|
+
|
|
+MIPS_MACHINE(LANTIQ_MACH_ARV4520PW,
|
|
+ "ARV4520PW",
|
|
+ "ARV4520PW - Airties WAV-281, Arcor A800",
|
|
+ arv4520pw_init);
|
|
+
|
|
+static void __init
|
|
+arv4525pw_init(void)
|
|
+{
|
|
+ lq_register_gpio();
|
|
+ lq_register_gpio_leds(arv4525pw_leds_gpio, ARRAY_SIZE(arv4525pw_leds_gpio));
|
|
+ lq_register_asc(0);
|
|
+ lq_register_asc(1);
|
|
+ lq_register_nor(&arv45xx_flash_data);
|
|
+ lq_pci_data.clock = PCI_CLOCK_INT;
|
|
+ lq_register_pci(&lq_pci_data);
|
|
+ lq_register_wdt();
|
|
+ lq_eth_data.mii_mode = MII_MODE;
|
|
+ arv45xx_register_ethernet();
|
|
+}
|
|
+
|
|
+MIPS_MACHINE(LANTIQ_MACH_ARV4525PW,
|
|
+ "ARV4525PW",
|
|
+ "ARV4525PW - Speedport W502V",
|
|
+ arv4525pw_init);
|
|
+
|
|
+static void __init
|
|
+arv7518pw_init(void)
|
|
+{
|
|
+ lq_register_gpio();
|
|
+ lq_register_gpio_ebu(ARV4520PW_LATCH_SWITCH);
|
|
+ lq_register_asc(0);
|
|
+ lq_register_asc(1);
|
|
+ lq_register_gpio_leds(arv7518pw_leds_gpio, ARRAY_SIZE(arv7518pw_leds_gpio));
|
|
+ lq_register_nor(&arv75xx_flash_data);
|
|
+ lq_register_pci(&lq_pci_data);
|
|
+ lq_register_wdt();
|
|
+ arv75xx_register_ethernet();
|
|
+ //arv7518_register_ath9k(mac);
|
|
+}
|
|
+
|
|
+MIPS_MACHINE(LANTIQ_MACH_ARV7518PW,
|
|
+ "ARV7518PW",
|
|
+ "ARV7518PW - ASTORIA",
|
|
+ arv7518pw_init);
|
|
+
|
|
+static void __init
|
|
+arv752dpw_init(void)
|
|
+{
|
|
+ lq_register_gpio();
|
|
+ lq_register_gpio_ebu(ARV752DPW_LATCH_DEFAULT);
|
|
+ lq_register_asc(0);
|
|
+ lq_register_asc(1);
|
|
+ lq_register_gpio_leds(arv752dpw_leds_gpio, ARRAY_SIZE(arv752dpw_leds_gpio));
|
|
+ lq_register_gpio_buttons(arv752dpw_gpio_buttons, ARRAY_SIZE(arv752dpw_gpio_buttons));
|
|
+ lq_register_nor(&arv75xx_flash_data);
|
|
+ lq_pci_data.irq[15] = (INT_NUM_IM2_IRL0 + 31);
|
|
+ lq_pci_data.gpio |= PCI_EXIN1 | PCI_REQ2;
|
|
+ lq_register_pci(&lq_pci_data);
|
|
+ lq_register_wdt();
|
|
+ arv75xx_register_ethernet();
|
|
+ gpio_request(32, "usb-power");
|
|
+ gpio_direction_output(32, 0);
|
|
+ mdelay(1);
|
|
+ __gpio_set_value(32, 1);
|
|
+ gpio_request(33, "relay");
|
|
+ gpio_direction_output(33, 1);
|
|
+}
|
|
+
|
|
+MIPS_MACHINE(LANTIQ_MACH_ARV752DPW,
|
|
+ "ARV752DPW",
|
|
+ "ARV752DPW - Arcor A803",
|
|
+ arv752dpw_init);
|