mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 12:59:43 +02:00
151259743b
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12718 3c298f89-4303-0410-b956-a3cf2f4a3e73
38 lines
1.1 KiB
Diff
38 lines
1.1 KiB
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -174,6 +174,12 @@
|
|
---help---
|
|
TI AR7 partitioning support
|
|
|
|
+config MTD_AR7_PARTS
|
|
+ tristate "TI AR7 partitioning support"
|
|
+ depends on MTD_PARTITIONS
|
|
+ ---help---
|
|
+ TI AR7 partitioning support
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_CHAR
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -13,6 +13,7 @@
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
|
|
--- a/drivers/mtd/maps/physmap.c
|
|
+++ b/drivers/mtd/maps/physmap.c
|
|
@@ -87,7 +87,8 @@
|
|
|
|
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
|
|
#ifdef CONFIG_MTD_PARTITIONS
|
|
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
|
|
+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
|
|
+ "ar7part", NULL };
|
|
#endif
|
|
|
|
static int physmap_flash_probe(struct platform_device *dev)
|