1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 23:56:48 +03:00
openwrt-xburst/package/ser/patches/no-libfl.patch
nbd d32ef4fdb8 add sip express router
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@455 3c298f89-4303-0410-b956-a3cf2f4a3e73
2005-03-25 18:44:22 +00:00

78 lines
2.1 KiB
Diff

diff -urN ser-0.9.0.old/Makefile.defs ser-0.9.0/Makefile.defs
--- ser-0.9.0.old/Makefile.defs 2004-12-16 18:50:40.000000000 +0100
+++ ser-0.9.0/Makefile.defs 2005-03-25 15:24:03.000000000 +0100
@@ -788,7 +788,7 @@
endif
YACC_FLAGS=-d -b cfg
# on solaris add -lxnet (e.g. LIBS= -lxnet)
-LIBS= -lfl -ldl -lresolv
+LIBS= -ldl -lresolv
#os specific stuff
@@ -826,7 +826,7 @@
endif
OLD_SOLARIS= $(shell echo "$(OSREL)" | \
sed -e 's/^5\.[0-6][^0-9]*$$/yes/' )
- LIBS+= -L/usr/local/lib -lfl -lxnet -lnsl
+ LIBS+= -L/usr/local/lib -lxnet -lnsl
ifeq ($(OLD_SOLARIS), yes)
LIBS+=-lposix4
else
@@ -841,9 +841,9 @@
ifneq ($(found_lock_method), yes)
DEFS+= -DUSE_PTHREAD_MUTEX # try pthread sems
found_lock_method=yes
- LIBS= -pthread -lfl #dlopen is in libc
+ LIBS= -pthread #dlopen is in libc
else
- LIBS= -lfl #dlopen is in libc
+ LIBS= #dlopen is in libc
endif
YACC=yacc
endif
@@ -858,7 +858,7 @@
# (symbols on openbsd are prefixed by "_")
YACC=yacc
# no sched_yield on openbsd unless linking with c_r (not recommended)
- LIBS= -lfl
+ LIBS=
OPENBSD_IS_AOUT= $(shell echo "$(OSREL)" | \
sed -e 's/^3\.[0-3][^0-9]*$$/yes/' |sed -e 's/^[0-2]\..*/yes/')
# exception: on sparc openbsd 3.2 is elf and not aout
@@ -885,7 +885,7 @@
found_lock_method=yes
endif
YACC=yacc
- LIBS= -lfl
+ LIBS=
endif
# OS X support, same as freebsd
@@ -899,9 +899,9 @@
ifneq ($(found_lock_method), yes)
DEFS+= -DUSE_PTHREAD_MUTEX # try pthread sems
found_lock_method=yes
- LIBS= -pthread -lfl -lresolv #dlopen is in libc
+ LIBS= -pthread -lresolv #dlopen is in libc
else
- LIBS= -lfl -lresolv #dlopen is in libc
+ LIBS= -lresolv #dlopen is in libc
endif
LDFLAGS= # darwin doesn't like -O2 or -E
MOD_LDFLAGS= -bundle -bundle_loader ../../$(MAIN_NAME)
diff -urN ser-0.9.0.old/cfg.lex ser-0.9.0/cfg.lex
--- ser-0.9.0.old/cfg.lex 2004-11-30 17:28:23.000000000 +0100
+++ ser-0.9.0/cfg.lex 2005-03-25 15:27:49.000000000 +0100
@@ -90,6 +90,10 @@
static char* addstr(struct str_buf *, char*, int);
static void count();
+ int yywrap(void)
+ {
+ return 1;
+ }
%}