mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 04:18:25 +02:00
c874812690
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10766 3c298f89-4303-0410-b956-a3cf2f4a3e73
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
--- linux-2.6.23.orig/drivers/input/misc/Kconfig 2007-08-21 06:33:06.000000000 +0200
|
|
+++ linux-2.6.23/drivers/input/misc/Kconfig 2007-10-08 10:57:23.000000000 +0200
|
|
@@ -178,4 +178,20 @@
|
|
Say Y here if you want to support the built-in real time clock
|
|
of the HP SDC controller.
|
|
|
|
+config INPUT_GPIO_BUTTONS
|
|
+ tristate "Polled GPIO buttons interface"
|
|
+ depends on GENERIC_GPIO
|
|
+ select INPUT_POLLDEV
|
|
+ help
|
|
+ This driver implements support for buttons connected
|
|
+ to GPIO pins of various CPUs (and some other chips).
|
|
+
|
|
+ Say Y here if your device has buttons connected
|
|
+ directly to such GPIO pins. Your board-specific
|
|
+ setup logic must also provide a platform device,
|
|
+ with configuration data saying which GPIOs are used.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the
|
|
+ module will be called gpio-buttons.
|
|
+
|
|
endif
|
|
--- linux-2.6.23.orig/drivers/input/misc/Makefile 2007-08-21 06:33:06.000000000 +0200
|
|
+++ linux-2.6.23/drivers/input/misc/Makefile 2007-10-08 10:50:12.000000000 +0200
|
|
@@ -18,3 +18,4 @@
|
|
obj-$(CONFIG_INPUT_YEALINK) += yealink.o
|
|
obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.o
|
|
obj-$(CONFIG_INPUT_UINPUT) += uinput.o
|
|
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
|