mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:49:42 +02:00
f40a767b0d
* adds stage1 lzma * new boards * fixes settings for PSC ram * lost of cleanups git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25694 3c298f89-4303-0410-b956-a3cf2f4a3e73
61 lines
1.9 KiB
Diff
61 lines
1.9 KiB
Diff
Add output like in linux kernel for current compiled file
|
|
Used normaly in combination with make option -s
|
|
|
|
Like in following example:
|
|
|
|
$ make -s V=1
|
|
[CC] tools/img2srec.c
|
|
[CC] tools/bmp_logo.c
|
|
[CC] examples/hello_world.c
|
|
|
|
--- a/config.mk
|
|
+++ b/config.mk
|
|
@@ -234,17 +234,47 @@ export TEXT_BASE PLATFORM_CPPFLAGS PLATF
|
|
|
|
#########################################################################
|
|
|
|
+ifndef KBUILD_VERBOSE
|
|
+ KBUILD_VERBOSE:=0
|
|
+endif
|
|
+ifeq ("$(origin V)", "command line")
|
|
+ KBUILD_VERBOSE:=$(V)
|
|
+endif
|
|
+ifeq (,$(findstring s,$(MAKEFLAGS)))
|
|
+ KBUILD_VERBOSE:=0
|
|
+endif
|
|
+
|
|
+ifneq ($(KBUILD_VERBOSE),0)
|
|
+ define MESSAGE
|
|
+ @printf " %s %s/%s\n" $(1) $(2) $(3)
|
|
+ endef
|
|
+else
|
|
+ define MESSAGE
|
|
+ endef
|
|
+endif
|
|
+
|
|
# Allow boards to use custom optimize flags on a per dir/file basis
|
|
BCURDIR := $(notdir $(CURDIR))
|
|
+
|
|
$(obj)%.s: %.S
|
|
+ $(call MESSAGE, [CPP],$(subst $(SRCTREE)/,,$(CURDIR)),$<)
|
|
+ #echo $(CPP) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $<
|
|
$(CPP) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $<
|
|
$(obj)%.o: %.S
|
|
+ $(call MESSAGE, [AS], $(subst $(SRCTREE)/,,$(CURDIR)),$<)
|
|
+ #echo $(CC) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $< -c
|
|
$(CC) $(AFLAGS) $(AFLAGS_$(@F)) $(AFLAGS_$(BCURDIR)) -o $@ $< -c
|
|
$(obj)%.o: %.c
|
|
+ $(call MESSAGE, [CC], $(subst $(SRCTREE)/,,$(CURDIR)),$<)
|
|
+ #echo $(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
|
|
$(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
|
|
$(obj)%.i: %.c
|
|
+ $(call MESSAGE, [CPP],$(subst $(SRCTREE)/,,$(CURDIR)),$<)
|
|
+ #echo $(CPP) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
|
|
$(CPP) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c
|
|
$(obj)%.s: %.c
|
|
+ $(call MESSAGE, [CC], $(subst $(SRCTREE)/,,$(CURDIR)),$<)
|
|
+ #echo $(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c -S
|
|
$(CC) $(CFLAGS) $(CFLAGS_$(@F)) $(CFLAGS_$(BCURDIR)) -o $@ $< -c -S
|
|
|
|
#########################################################################
|