mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:37:29 +02:00
e6c4ccac7d
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26676 3c298f89-4303-0410-b956-a3cf2f4a3e73
24 lines
881 B
Diff
24 lines
881 B
Diff
--- a/config.mk
|
|
+++ b/config.mk
|
|
@@ -64,9 +64,17 @@ HOSTSTRIP = strip
|
|
#
|
|
|
|
ifeq ($(HOSTOS),darwin)
|
|
-HOSTCC = cc
|
|
-HOSTCFLAGS += -traditional-cpp
|
|
-HOSTLDFLAGS += -multiply_defined suppress
|
|
+#get the major and minor product version (e.g. '10' and '6' for Snow Leopard)
|
|
+DARWIN_MAJOR_VERSION = $(shell sw_vers -productVersion | cut -f 1 -d '.')
|
|
+DARWIN_MINOR_VERSION = $(shell sw_vers -productVersion | cut -f 2 -d '.')
|
|
+
|
|
+before-snow-leopard = $(shell if [ $(DARWIN_MAJOR_VERSION) -le 10 -a \
|
|
+ $(DARWIN_MINOR_VERSION) -le 5 ] ; then echo "$(1)"; else echo "$(2)"; fi ;)
|
|
+
|
|
+# Snow Leopards build environment has no longer restrictions as described above
|
|
+HOSTCC = $(call before-snow-leopard, "cc", "gcc")
|
|
+HOSTCFLAGS += $(call before-snow-leopard, "-traditional-cpp")
|
|
+HOSTLDFLAGS += $(call before-snow-leopard, "-multiply_defined suppress")
|
|
else
|
|
HOSTCC = gcc
|
|
endif
|