mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:25:20 +02:00
0ec45ff596
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15860 3c298f89-4303-0410-b956-a3cf2f4a3e73
22 lines
727 B
Diff
22 lines
727 B
Diff
--- a/arch/mips/Makefile
|
|
+++ b/arch/mips/Makefile
|
|
@@ -739,6 +739,7 @@ LINKFLAGS += -T arch/$(ARCH)/ld.script
|
|
HEAD := arch/mips/kernel/head.o arch/mips/kernel/init_task.o
|
|
|
|
SUBDIRS := $(addprefix arch/mips/, tools) $(SUBDIRS) $(addprefix arch/mips/, kernel mm lib)
|
|
+$(SUBDIRS): $(TOPDIR)/include/asm-$(ARCH)/offset.h
|
|
CORE_FILES := arch/mips/kernel/kernel.o arch/mips/mm/mm.o $(CORE_FILES)
|
|
LIBS := arch/mips/lib/lib.a $(LIBS)
|
|
|
|
@@ -785,7 +786,7 @@ archmrproper:
|
|
$(MAKE) -C arch/$(ARCH)/tools mrproper
|
|
|
|
archdep:
|
|
- if [ ! -f $(TOPDIR)/include/asm-$(ARCH)/offset.h ]; then \
|
|
- touch $(TOPDIR)/include/asm-$(ARCH)/offset.h; \
|
|
- fi;
|
|
@$(MAKEBOOT) dep
|
|
+
|
|
+$(TOPDIR)/include/asm-$(ARCH)/offset.h:
|
|
+ @$(MAKE) -C arch/mips/tools
|