mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 17:22:49 +02:00
549710c306
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9258 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
1.0 KiB
Diff
28 lines
1.0 KiB
Diff
Index: linux-2.6.23/drivers/net/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.23.orig/drivers/net/Kconfig
|
|
+++ linux-2.6.23/drivers/net/Kconfig
|
|
@@ -589,6 +589,10 @@ config MIPS_AU1X00_ENET
|
|
If you have an Alchemy Semi AU1X00 based system
|
|
say Y. Otherwise, say N.
|
|
|
|
+config MIPS_ADM5120_ENET
|
|
+ tristate "MIPS ADM5120 Ethernet switch support"
|
|
+ depends on NET_ETHERNET && MIPS_ADM5120
|
|
+
|
|
config NET_SB1250_MAC
|
|
tristate "SB1250 Ethernet support"
|
|
depends on SIBYTE_SB1xxx_SOC
|
|
Index: linux-2.6.23/drivers/net/Makefile
|
|
===================================================================
|
|
--- linux-2.6.23.orig/drivers/net/Makefile
|
|
+++ linux-2.6.23/drivers/net/Makefile
|
|
@@ -174,6 +174,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
|
|
# This is also a 82596 and should probably be merged
|
|
obj-$(CONFIG_LP486E) += lp486e.o
|
|
|
|
+obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
|
|
obj-$(CONFIG_ETH16I) += eth16i.o
|
|
obj-$(CONFIG_ZORRO8390) += zorro8390.o
|
|
obj-$(CONFIG_HPLANCE) += hplance.o 7990.o
|