1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 19:57:09 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.24/310-adm5120_wdt.patch
juhosg 13ac16c77f [adm5120] add preliminary support for 2.6.24
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10329 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-01-30 15:25:48 +00:00

36 lines
1.3 KiB
Diff

Index: linux-2.6.24/drivers/watchdog/Kconfig
===================================================================
--- linux-2.6.24.orig/drivers/watchdog/Kconfig
+++ linux-2.6.24/drivers/watchdog/Kconfig
@@ -607,6 +607,18 @@ config SBC_EPX_C3_WATCHDOG
# MIPS Architecture
+config ADM5120_WDT
+ tristate "Infineon ADM5120 SoC hardware watchdog"
+ depends on WATCHDOG && MIPS_ADM5120
+ help
+ This is a driver for hardware watchdog integrated in Infineon
+ ADM5120 SoC. This watchdog simply watches your kernel to make sure
+ it doesn't freeze, and if it does, it reboots your computer after a
+ certain amount of time.
+
+ To compile this driver as a module, choose M here: the module will be
+ called adm5120_wdt.
+
config INDYDOG
tristate "Indy/I2 Hardware Watchdog"
depends on SGI_IP22
Index: linux-2.6.24/drivers/watchdog/Makefile
===================================================================
--- linux-2.6.24.orig/drivers/watchdog/Makefile
+++ linux-2.6.24/drivers/watchdog/Makefile
@@ -89,6 +89,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
# M68KNOMMU Architecture
# MIPS Architecture
+obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
obj-$(CONFIG_INDYDOG) += indydog.o
obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o