1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-19 19:48:04 +03:00
openwrt-xburst/package/iptraf/patches/iptraf-2.7.0-cross_compile.patch
nico 81b3eea3b6 add iptraf (thanks to Thomas Reifferscheid)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2048 3c298f89-4303-0410-b956-a3cf2f4a3e73
2005-10-04 20:45:16 +00:00

30 lines
803 B
Diff

diff -ruN iptraf-2.7.0-old/support/Makefile iptraf-2.7.0-new/support/Makefile
--- iptraf-2.7.0-old/support/Makefile 2001-11-27 09:37:11.000000000 +0100
+++ iptraf-2.7.0-new/support/Makefile 2005-10-03 18:40:40.000000000 +0200
@@ -3,16 +3,21 @@
OBJS = input.o menurt.o listbox.o winops.o labels.o \
msgboxes.o
+AR=ar
+CC=cc
+RANLIB=ranlib
+CFLAGS= -O2 -g -fPIC
+
all: libtextbox.a
libtextbox.a: $(OBJS)
rm -rf libtextbox.a
- ar cq libtextbox.a $(OBJS)
- ranlib libtextbox.a
-# gcc -shared -o libtextbox.so $(OBJS)
+ $(AR) cq libtextbox.a $(OBJS)
+ $(RANLIB) libtextbox.a
+# $(CC) -shared -o libtextbox.so $(OBJS)
%.o: %.c *.h
- gcc -O2 -g -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
+ $(CC) $(CFLAGS) -Wall $(INCLUDEDIR) -c -o $*.o $<
clean:
rm -rf *.o *~ libtextbox.a libtextbox.so