1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 17:34:35 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.26/004-extra_optimization.patch
juhosg e1ee35b052 [kernel] refresh generic 2.6.26 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11336 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-06-02 19:49:28 +00:00

13 lines
359 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -537,6 +537,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)