mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:02:50 +02:00
bc624321e8
it allows building a package multiple times in one pass with different build dirs, based on the same build settings. replaces templating hacks like the one used in the hostapd package git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18357 3c298f89-4303-0410-b956-a3cf2f4a3e73
83 lines
1.9 KiB
Makefile
83 lines
1.9 KiB
Makefile
#
|
|
# Copyright (C) 2006 OpenWrt.org
|
|
#
|
|
# This is free software, licensed under the GNU General Public License v2.
|
|
# See /LICENSE for more information.
|
|
#
|
|
|
|
ifneq ($(DUMP),)
|
|
|
|
dumpinfo: FORCE
|
|
|
|
define Config/template
|
|
Preconfig: $(1)
|
|
Preconfig-Type: $(2)
|
|
Preconfig-Default: $(3)
|
|
Preconfig-Label: $(4)
|
|
|
|
endef
|
|
|
|
define Config
|
|
Preconfig/$(1) = $$(call Config/template,$(1),$(2),$(3),$(4))
|
|
preconfig_$$(1) += $(1)
|
|
endef
|
|
|
|
define Dumpinfo/Package
|
|
$(info Package: $(1)
|
|
$(if $(MENU),Menu: $(MENU)
|
|
)$(if $(SUBMENU),Submenu: $(SUBMENU)
|
|
)$(if $(SUBMENUDEP),Submenu-Depends: $(SUBMENUDEP)
|
|
)$(if $(DEFAULT),Default: $(DEFAULT)
|
|
)$(if $(findstring $(PREREQ_CHECK),1),Prereq-Check: 1
|
|
)Version: $(VERSION)
|
|
Depends: $(DEPENDS)
|
|
Provides: $(PROVIDES)
|
|
$(if $(VARIANT),Build-Variant: $(VARIANT)
|
|
)$(if $(PKG_BUILD_DEPENDS),Build-Depends: $(PKG_BUILD_DEPENDS)
|
|
)$(if $(HOST_BUILD_DEPENDS),Build-Depends/host: $(HOST_BUILD_DEPENDS)
|
|
)$(if $(BUILD_TYPES),Build-Types: $(BUILD_TYPES)
|
|
)Section: $(SECTION)
|
|
Category: $(CATEGORY)
|
|
Title: $(TITLE)
|
|
Maintainer: $(MAINTAINER)
|
|
Source: $(PKG_SOURCE)
|
|
Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
|
|
$(if $(KCONFIG),Kernel-Config: $(KCONFIG)
|
|
)$(if $(BUILDONLY),Build-Only: $(BUILDONLY)
|
|
)Description: $(if $(Package/$(1)/description),$(Package/$(1)/description),$(TITLE))
|
|
$(if $(URL),$(URL)
|
|
)@@
|
|
$(if $(Package/$(1)/config),Config:
|
|
$(Package/$(1)/config)
|
|
@@
|
|
)$(foreach pc,$(preconfig_$(1)),
|
|
$(Preconfig/$(pc))))
|
|
endef
|
|
|
|
define Feature/Default
|
|
TARGET_NAME:=
|
|
TARGET_TITLE:=
|
|
PRIORITY:=
|
|
NAME:=
|
|
endef
|
|
|
|
define Feature
|
|
$(eval $(Feature/Default))
|
|
$(eval $(Feature/$(1)))
|
|
$(if $(DUMP),$(call Dumpinfo/Feature,$(1)))
|
|
endef
|
|
|
|
define Dumpinfo/Feature
|
|
$(info Feature: $(TARGET_NAME)_$(1)
|
|
Target-Name: $(TARGET_NAME)
|
|
Target-Title: $(TARGET_TITLE)
|
|
Feature-Name: $(NAME)
|
|
$(if $(PRIORITY),Feature-Priority: $(PRIORITY)
|
|
)Feature-Description:
|
|
$(Feature/$(1)/description)
|
|
@@
|
|
)
|
|
endef
|
|
|
|
endif
|