mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:50:20 +02:00
641c4de73d
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15958 3c298f89-4303-0410-b956-a3cf2f4a3e73
20 lines
426 B
Diff
20 lines
426 B
Diff
|
|
Use values exported from $(TOPDIR)/rules.mk for determining
|
|
the target system instead of the host configuration
|
|
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -8,9 +8,9 @@ SYSCONF=/etc
|
|
# if [ -d /NextApps ]; then
|
|
# system="NeXTStep"
|
|
# else
|
|
- system=`uname -s`
|
|
- release=`uname -r`
|
|
- arch=`uname -m`
|
|
+ system=${UNAME_S:-`uname -s`}
|
|
+ release=${UNAME_R:-`uname -r`}
|
|
+ arch=${UNAME_M:-`uname -m`}
|
|
# fi
|
|
state="unknown"
|
|
|