mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:19:20 +02:00
a210854b74
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16048 3c298f89-4303-0410-b956-a3cf2f4a3e73
32 lines
1.0 KiB
Diff
32 lines
1.0 KiB
Diff
--- a/drivers/power/Kconfig
|
|
+++ b/drivers/power/Kconfig
|
|
@@ -88,4 +88,16 @@ config CHARGER_PCF50633
|
|
help
|
|
Say Y to include support for NXP PCF50633 Main Battery Charger.
|
|
|
|
+config BATTERY_BQ27000_HDQ
|
|
+ tristate "BQ27000 HDQ battery monitor driver"
|
|
+ help
|
|
+ Say Y to enable support for the battery on the Neo Freerunner
|
|
+
|
|
+config HDQ_GPIO_BITBANG
|
|
+ bool "Generic gpio based HDQ bitbang"
|
|
+ help
|
|
+ Say Y to enable supoort for generic gpio based HDQ bitbang driver.
|
|
+ This can not be built as a module.
|
|
+
|
|
endif # POWER_SUPPLY
|
|
+
|
|
--- a/drivers/power/Makefile
|
|
+++ b/drivers/power/Makefile
|
|
@@ -25,4 +25,7 @@ obj-$(CONFIG_BATTERY_TOSA) += tosa_batte
|
|
obj-$(CONFIG_BATTERY_WM97XX) += wm97xx_battery.o
|
|
obj-$(CONFIG_BATTERY_BQ27x00) += bq27x00_battery.o
|
|
obj-$(CONFIG_BATTERY_DA9030) += da9030_battery.o
|
|
-obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
|
|
\ No newline at end of file
|
|
+obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
|
|
+obj-$(CONFIG_BATTERY_BQ27000_HDQ) += bq27000_battery.o
|
|
+
|
|
+obj-$(CONFIG_HDQ_GPIO_BITBANG) += hdq.o
|