mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:02:49 +02:00
c5552ad039
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21952 3c298f89-4303-0410-b956-a3cf2f4a3e73
22 lines
712 B
Diff
22 lines
712 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -308,4 +308,11 @@ config LEDS_TRIGGER_MORSE
|
|
tristate "LED Morse Trigger"
|
|
depends on LEDS_TRIGGERS
|
|
|
|
+config LEDS_TRIGGER_NETDEV
|
|
+ tristate "LED Netdev Trigger"
|
|
+ depends on NET && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by network device activity.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -41,3 +41,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
|
|
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|