1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 21:37:37 +03:00
openwrt-xburst/target/linux/ar71xx/patches-2.6.28/109-mtd-wrt160nl-trx-parser.patch
juhosg 481c294462 [ar71xx] move the trx parser out from the patch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17176 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-08-08 12:08:41 +00:00

38 lines
1.2 KiB
Diff

--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -735,6 +735,9 @@ static int __devinit m25p_probe(struct s
#ifdef CONFIG_MTD_REDBOOT_PARTS
"RedBoot",
#endif
+#ifdef CONFIG_MTD_WRT160NL_PARTS
+ "wrt160nl",
+#endif
NULL, };
nr_parts = parse_mtd_partitions(&flash->mtd,
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -172,6 +172,12 @@ config MTD_AR7_PARTS
---help---
TI AR7 partitioning support
+config MTD_WRT160NL_PARTS
+ tristate "Linksys WRT160NL partitioning support"
+ depends on MTD_PARTITIONS && AR71XX_MACH_WRT160NL
+ ---help---
+ Linksys WRT160NL partitioning support
+
config MTD_MYLOADER_PARTS
tristate "MyLoader partition parsing"
depends on MTD_PARTITIONS && (ADM5120 || ATHEROS || ATHEROS_AR71XX)
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
+obj-$(CONFIG_MTD_WRT160NL_PARTS) += wrt160nl_part.o
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o