1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-16 00:48:03 +03:00
openwrt-xburst/target/linux/ramips/patches-2.6.36/104-ramips-watchdog-driver.patch
juhosg 8e047f5e1f ramips: add watchdog driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25126 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-01-26 20:48:41 +00:00

27 lines
760 B
Diff

--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -916,6 +916,13 @@ config OCTEON_WDT
from the first interrupt, it is then only poked when the
device is written.
+config RAMIPS_WDT
+ tristate "Ralink RT288X/RT305X Watchdog Timer"
+ depends on SOC_RT288X || SOC_RT305X
+ help
+ Hardware driver for the built-in watchdog timer on the
+ Ralink RT288X/RT305X SoCs.
+
# PARISC Architecture
# POWERPC Architecture
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -118,6 +118,7 @@ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
+obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
# PARISC Architecture