1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 04:23:16 +03:00
openwrt-xburst/package/vpnc/patches/01-cross.patch
nico 1abc6db611 rename the patch to better match its purpose,
add target optimization cflags, 
prevent host system detection to set compile-time options.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2688 3c298f89-4303-0410-b956-a3cf2f4a3e73
2005-12-15 12:55:38 +00:00

38 lines
1.3 KiB
Diff

diff -ruN vpnc-0.3.3-old/Makefile vpnc-0.3.3-new/Makefile
--- vpnc-0.3.3-old/Makefile 2005-05-01 22:30:35.000000000 +0200
+++ vpnc-0.3.3-new/Makefile 2005-12-13 17:23:26.000000000 +0100
@@ -23,25 +23,26 @@
MANDIR=$(PREFIX)/share/man
CC=gcc
-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
-LDFLAGS=-g $(shell libgcrypt-config --libs)
+CFLAGS=-W -Wall -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
+LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib $(shell libgcrypt-config --libs)
-ifeq ($(shell uname -s), Linux)
+OS=$(shell uname -s)
+ifeq ($(OS), Linux)
SYSDEP=sysdep-linux.o
endif
-ifeq ($(shell uname -s), FreeBSD)
+ifeq ($(OS), FreeBSD)
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN
SYSDEP=sysdep-bsd.o
endif
-ifeq ($(shell uname -s), NetBSD)
+ifeq ($(OS), NetBSD)
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN
SYSDEP=sysdep-bsd.o
endif
-ifeq ($(shell uname -s), OpenBSD)
+ifeq ($(OS), OpenBSD)
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN -DNEED_IPLEN_FIX -DNEW_TUN
SYSDEP=sysdep-bsd.o
endif
-ifeq ($(shell uname -s), SunOS)
+ifeq ($(OS), SunOS)
CFLAGS += -DNEED_IPLEN_FIX
LDFLAGS += -lnsl -lresolv -lsocket
SYSDEP=sysdep-svr4.o