mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 19:06:16 +02:00
94b5af79b4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13137 3c298f89-4303-0410-b956-a3cf2f4a3e73
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
--- a/drivers/mtd/devices/at91_dataflash.c
|
|
+++ b/drivers/mtd/devices/at91_dataflash.c
|
|
@@ -175,7 +175,7 @@ static struct mtd_partition static_parti
|
|
};
|
|
#endif
|
|
|
|
-static const char *part_probes[] = { "cmdlinepart", NULL, };
|
|
+static const char *part_probes[] = { "cmdlinepart", "at91part", NULL, };
|
|
|
|
#endif
|
|
|
|
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -168,6 +168,12 @@ config MTD_OF_PARTS
|
|
the partition map from the children of the flash node,
|
|
as described in Documentation/powerpc/booting-without-of.txt.
|
|
|
|
+config MTD_AT91_PARTS
|
|
+ tristate "Atmel AT91 partitioning support"
|
|
+ depends on MTD_PARTITIONS && ARCH_AT91RM9200 && AT91_SPI
|
|
+ ---help---
|
|
+ Atmel AT91 partitioning support
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_CHAR
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
+obj-$(CONFIG_MTD_AT91_PARTS) += at91part.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
|