mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-09 22:44:04 +02:00
e570388548
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14587 3c298f89-4303-0410-b956-a3cf2f4a3e73
140 lines
3.4 KiB
Diff
140 lines
3.4 KiB
Diff
--- a/bfd/configure
|
|
+++ b/bfd/configure
|
|
@@ -3576,7 +3576,7 @@ irix5* | irix6*)
|
|
;;
|
|
|
|
# This must be Linux ELF.
|
|
-linux-gnu*)
|
|
+linux-gnu*|linux-uclibc*)
|
|
lt_cv_deplibs_check_method=pass_all
|
|
;;
|
|
|
|
--- a/binutils/configure
|
|
+++ b/binutils/configure
|
|
@@ -3411,7 +3411,7 @@ irix5* | irix6*)
|
|
;;
|
|
|
|
# This must be Linux ELF.
|
|
-linux-gnu*)
|
|
+linux-gnu*|linux-uclibc*)
|
|
lt_cv_deplibs_check_method=pass_all
|
|
;;
|
|
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -1276,7 +1276,7 @@ case "${target}" in
|
|
am33_2.0-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
- sh-*-linux*)
|
|
+ sh*-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
@@ -1584,7 +1584,7 @@ case "${target}" in
|
|
romp-*-*)
|
|
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
;;
|
|
- sh-*-* | sh64-*-*)
|
|
+ sh*-*-* | sh64-*-*)
|
|
case "${host}" in
|
|
i[3456789]86-*-vsta) ;; # don't add gprof back in
|
|
i[3456789]86-*-go32*) ;; # don't add gprof back in
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -468,7 +468,7 @@ case "${target}" in
|
|
am33_2.0-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
- sh-*-linux*)
|
|
+ sh*-*-linux*)
|
|
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
|
;;
|
|
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
|
@@ -776,7 +776,7 @@ case "${target}" in
|
|
romp-*-*)
|
|
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
|
;;
|
|
- sh-*-* | sh64-*-*)
|
|
+ sh*-*-* | sh64-*-*)
|
|
case "${host}" in
|
|
i[[3456789]]86-*-vsta) ;; # don't add gprof back in
|
|
i[[3456789]]86-*-go32*) ;; # don't add gprof back in
|
|
--- a/gas/configure
|
|
+++ b/gas/configure
|
|
@@ -3411,7 +3411,7 @@ irix5* | irix6*)
|
|
;;
|
|
|
|
# This must be Linux ELF.
|
|
-linux-gnu*)
|
|
+linux-gnu*|linux-uclibc*)
|
|
lt_cv_deplibs_check_method=pass_all
|
|
;;
|
|
|
|
--- a/gprof/configure
|
|
+++ b/gprof/configure
|
|
@@ -3414,6 +3414,11 @@ linux-gnu*)
|
|
lt_cv_deplibs_check_method=pass_all
|
|
;;
|
|
|
|
+linux-uclibc*)
|
|
+ lt_cv_deplibs_check_method=pass_all
|
|
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
|
+ ;;
|
|
+
|
|
netbsd* | knetbsd*-gnu)
|
|
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
|
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
|
--- a/ld/configure
|
|
+++ b/ld/configure
|
|
@@ -3413,7 +3413,7 @@ irix5* | irix6*)
|
|
;;
|
|
|
|
# This must be Linux ELF.
|
|
-linux-gnu*)
|
|
+linux-gnu*|linux-uclibc*)
|
|
lt_cv_deplibs_check_method=pass_all
|
|
;;
|
|
|
|
--- a/libtool.m4
|
|
+++ b/libtool.m4
|
|
@@ -739,7 +739,7 @@ irix5* | irix6*)
|
|
;;
|
|
|
|
# This must be Linux ELF.
|
|
-linux-gnu*)
|
|
+linux-gnu*|linux-uclibc*)
|
|
lt_cv_deplibs_check_method=pass_all
|
|
;;
|
|
|
|
--- a/ltconfig
|
|
+++ b/ltconfig
|
|
@@ -602,6 +602,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-
|
|
|
|
# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
|
|
case $host_os in
|
|
+linux-uclibc*) ;;
|
|
linux-gnu*) ;;
|
|
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
|
|
esac
|
|
@@ -1247,7 +1248,7 @@ linux-gnuoldld* | linux-gnuaout* | linux
|
|
;;
|
|
|
|
# This must be Linux ELF.
|
|
-linux-gnu*)
|
|
+linux-gnu*|linux-uclibc*)
|
|
version_type=linux
|
|
need_lib_prefix=no
|
|
need_version=no
|
|
--- a/opcodes/configure
|
|
+++ b/opcodes/configure
|
|
@@ -3579,7 +3579,7 @@ irix5* | irix6*)
|
|
;;
|
|
|
|
# This must be Linux ELF.
|
|
-linux-gnu*)
|
|
+linux-gnu*|linux-uclibc*)
|
|
lt_cv_deplibs_check_method=pass_all
|
|
;;
|
|
|