1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 06:39:27 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.26/004-extra_optimization.patch
kaloz 8540d5d19e add generic 2.6.26 patches/files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11323 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-06-02 08:22:56 +00:00

13 lines
359 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -533,6 +533,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)